diff options
author | Iyán Méndez Veiga | 2024-05-08 13:16:16 +0200 |
---|---|---|
committer | Iyán Méndez Veiga | 2024-05-08 13:16:16 +0200 |
commit | 591f1a4f379a0d726dbe43dd98f50a3b59b8a9ce (patch) | |
tree | f4ba0dcd3eed98712e010984fd8c6ae95d93990b /PKGBUILD | |
parent | 796ad47f361e7ca9ed1ba3124cf56c5ac67fafa3 (diff) | |
download | aur-591f1a4f379a0d726dbe43dd98f50a3b59b8a9ce.tar.gz |
upgpkg: python-qiskit-finance 0.4.1-1
python 3.12 rebuild
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 56 |
1 files changed, 28 insertions, 28 deletions
@@ -4,50 +4,50 @@ pkgname=python-${_pkgname} pkgver=0.4.1 pkgrel=1 pkgdesc="Quantum Finance package for IBM qiskit framework" -arch=('any') -url="https://github.com/qiskit-community/qiskit-finance" -license=('Apache-2.0') +arch=(any) +url=https://github.com/qiskit-community/qiskit-finance +license=(Apache-2.0) depends=( - 'python-certifi' - 'python-fastdtw' - 'python-nasdaq-data-link' - 'python-numpy' - 'python-pandas' - 'python-psutil' - 'python-qiskit' - 'python-qiskit-algorithms' - 'python-qiskit-optimization' - 'python-scipy' - 'python-urllib3' - 'python-yfinance' + python-certifi + python-fastdtw + python-nasdaq-data-link + python-numpy + python-pandas + python-psutil + python-qiskit + python-qiskit-algorithms + python-qiskit-optimization + python-scipy + python-urllib3 + python-yfinance ) makedepends=( - 'python-build' - 'python-installer' - 'python-setuptools' - 'python-wheel' + python-build + python-installer + python-setuptools + python-wheel ) checkdepends=( - 'python-ddt' - 'python-pytest' + python-ddt + python-pytest ) -source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/qiskit-community/${_pkgname}/archive/${pkgver}.tar.gz") +source=($_pkgname-$pkgver.tar.gz::https://github.com/qiskit-community/$_pkgname/archive/$pkgver.tar.gz) b2sums=('2258bf0d30b5ad46e610e3adcc823da6ae50f3601e7e4ef5e39e41a3e3edbd8e58b3b8cfbee4b82ca5214952c2cdbc23448dcb64a6cfbe7e5a0746e56956497b') build() { - cd "${srcdir}/${_pkgname}-${pkgver}" + cd $_pkgname-$pkgver python -m build --wheel --no-isolation } check() { + cd $_pkgname-$pkgver local _site_packages=$(python -c "import site; print(site.getsitepackages()[0])") - cd "${_pkgname}-${pkgver}" - python -m installer --destdir=test_dir dist/*.whl - PYTHONPATH="test_dir/$_site_packages:$PYTHONPATH" pytest + python -m installer --destdir=../test_dir dist/*.whl + PYTHONPATH=../test_dir/$_site_packages pytest } package() { - cd "${srcdir}/${_pkgname}-${pkgver}" + cd $_pkgname-$pkgver python -m installer --destdir="$pkgdir" dist/*.whl - install -D -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE" + install -D -m644 LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE } |