summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIyán Méndez Veiga2022-11-22 22:51:50 +0100
committerIyán Méndez Veiga2022-11-22 22:51:50 +0100
commit30455f1cc25e6c88b026db9d5875d2f3a1bf75b1 (patch)
treec810c37f63dd6af5407364734316819244c73a92 /PKGBUILD
parent65a219f8ecea74cb55ebdcd4a386eebe746862e9 (diff)
downloadaur-30455f1cc25e6c88b026db9d5875d2f3a1bf75b1.tar.gz
upgpkg: python-qiskit-terra 0.22.2-1
upstream release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 15 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 01b1f19f3161..adeede44b97e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Iyán Méndez Veiga <me (at) iyanmv (dot) com>
_pkgname=qiskit-terra
pkgname=python-${_pkgname}
-pkgver=0.22.0
+pkgver=0.22.2
pkgrel=1
pkgdesc="An open-source framework for working with noisy quantum computers at the level of pulses, circuits, and algorithms"
arch=('x86_64')
@@ -14,7 +14,7 @@ depends=(
'python-numpy'
'python-ply'
'python-psutil'
- 'python-retworkx'
+ 'python-rustworkx'
'python-scipy'
'python-stevedore'
'python-symengine'
@@ -42,8 +42,19 @@ makedepends=(
'python-setuptools-rust'
'python-wheel'
)
-source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/Qiskit/${_pkgname}/archive/${pkgver}.tar.gz")
-b2sums=('208f554de7fd6c11e76879a8c4c08f27859f1dd729494c3ab372e73e5205def0f97a5dac16bd26f632a80428d5ead1797509f67e78983eebdc34d092158a5124')
+source=(
+ "${_pkgname}-${pkgver}.tar.gz::https://github.com/Qiskit/${_pkgname}/archive/${pkgver}.tar.gz"
+ "rustworkx.patch"
+)
+b2sums=(
+ '2bc25a93e573fa9fa464f3cac5df2fefd0cbb372ff718e4ddc55ea377a1cb532002c1589b1ee551ceeb3fa2b5ba5c49f1a749ec86e85578e64e69e642558ba6a'
+ '94133e4479ad918a8b40bdb53c91e44f2cd5eb85ed3831b559e643f3cf5b985ad11fa27bb16096995e59af67611902595e0e6b10f2b71e8624ff8eadb9a36a1f'
+)
+
+prepare() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ patch --forward --strip=1 --input="${srcdir}/rustworkx.patch"
+}
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"