summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIyán Méndez Veiga2019-12-10 08:10:53 +0100
committerIyán Méndez Veiga2019-12-10 08:10:53 +0100
commit5c60498076c8bb40e7dccec9e1c98f307be35411 (patch)
tree1fcfc66386fbc800c59328efcf76072c2c2aa40f /PKGBUILD
parent2968166cf7a8af9220f38719339759a0ca7af7bb (diff)
downloadaur-5c60498076c8bb40e7dccec9e1c98f307be35411.tar.gz
Update to 0.11.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD46
1 files changed, 26 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 451742e0af67..a7751e2bc99d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,38 @@
# Maintainer: Iyán Méndez Veiga <me (at) iyanmv (dot) com>
_pkgname=qiskit-terra
pkgname=python-${_pkgname}
-pkgver=0.10.0
+pkgver=0.11.0
pkgrel=1
pkgdesc="An open-source framework for working with noisy quantum computers at the level of pulses, circuits, and algorithms"
arch=('x86_64')
url="https://github.com/Qiskit/qiskit-terra"
license=('Apache')
-conflicts=('python-qiskit-sdk-git'
- 'python-qiskit-api-git')
-depends=('python-jsonschema'
- 'python-marshmallow'
- 'python-marshmallow-polyfield'
- 'python-networkx'
- 'python-numpy'
- 'python-ply'
- 'python-psutil'
- 'python-scipy'
- 'python-sympy'
- 'python-dill')
-optdepends=('python-matplotlib: plotting support'
- 'python-qiskit-aer: high performance simulator framework'
- 'python-qiskit-ignis: noise framework'
- 'python-qiskit-aqua: algorithms for quantum computing applications'
- 'python-qiskit-ibmq: IBM Q account support')
+conflicts=(
+ 'python-qiskit-sdk-git'
+ 'python-qiskit-api-git'
+)
+depends=(
+ 'python-jsonschema'
+ 'python-marshmallow'
+ 'python-marshmallow-polyfield'
+ 'python-networkx'
+ 'python-numpy'
+ 'python-ply'
+ 'python-psutil'
+ 'python-scipy'
+ 'python-sympy'
+ 'python-dill'
+)
+optdepends=(
+ 'python-matplotlib: plotting support'
+ 'python-qiskit-aer: high performance simulator framework'
+ 'python-qiskit-ignis: noise framework'
+ 'python-qiskit-aqua: algorithms for quantum computing applications'
+ 'python-qiskit-ibmq: IBM Q account support'
+)
makedepends=('python-setuptools')
source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/Qiskit/${_pkgname}/archive/${pkgver}.tar.gz")
-sha256sums=('be5f65ac2c3366512e722f09af69d1552453c30ea925d20c2247cb6b5f88daaf')
+sha256sums=('e7b279fc317231a978a5f24b6f3db5b1541d27fbb7a543daf3d702f3edcf4c68')
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"
@@ -36,4 +42,4 @@ build() {
package() {
cd "${srcdir}/${_pkgname}-${pkgver}"
python setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
-} \ No newline at end of file
+}