summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIyán Méndez Veiga2022-07-01 14:26:57 +0200
committerIyán Méndez Veiga2022-07-01 14:26:57 +0200
commitf17be9eaa92a4b39633ac36b443c78b178214b38 (patch)
tree36eb6ee3994ca687add59d7ad0c044306090a79d /PKGBUILD
parent983263aa67b4de300e99ac2508b8a2b485c8458f (diff)
downloadaur-f17be9eaa92a4b39633ac36b443c78b178214b38.tar.gz
upgpkg: python-qiskit-terra 0.21.0-1
upstream release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 3 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f2a5afd23192..1e8a0f23659c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Iyán Méndez Veiga <me (at) iyanmv (dot) com>
_pkgname=qiskit-terra
pkgname=python-${_pkgname}
-pkgver=0.20.2
+pkgver=0.21.0
pkgrel=1
pkgdesc="An open-source framework for working with noisy quantum computers at the level of pulses, circuits, and algorithms"
arch=('x86_64')
@@ -9,7 +9,6 @@ url="https://github.com/Qiskit/qiskit-terra"
license=('Apache')
depends=(
'cython'
- 'python-constraint'
'python-dateutil'
'python-dill'
'python-numpy'
@@ -25,6 +24,7 @@ depends=(
optdepends=(
'cplex: commercial solver for mathematical optimization problems'
+ 'python-constraint: support for handling CSPs (Constraint Solving Problems)'
'python-docplex: IBM Decision Optimization CPLEX Modeling'
'python-ipywidgets: IPython HTML widgets for Jupyter'
'python-matplotlib: plotting support'
@@ -42,25 +42,14 @@ makedepends=(
'python-setuptools-rust'
'python-wheel'
)
-checkdepends=(
- 'python-pytest'
- 'python-hypothesis'
-)
source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/Qiskit/${_pkgname}/archive/${pkgver}.tar.gz")
-b2sums=('715b6fb93e5b6e4d5716c7573e478e8afef476315874d2a6807a935ce7e816f108de6b8ba8e51831700566ae3986bc60f57eb76fdf15764857de22155a3b6abb')
+b2sums=('408a5286687c5ed2f3e775ce2994b3191e7887fb9fd9cf4a6950f2fa79956967b46d2f23d97b0c63a4e1f4b2add95c07bbce4b1f2513b1713a2d714f8585725c')
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"
python -m build --wheel --no-isolation
}
-#check() {
-# cd "${srcdir}/${_pkgname}-${pkgver}"
-# python -m installer --destdir="$srcdir/test" dist/*.whl
-# export PYTHONPATH="$srcdir"/test/usr/lib/python3.10/site-packages
-# python -m pytest test/python
-#}
-
package() {
cd "${srcdir}/${_pkgname}-${pkgver}"
python -m installer --destdir="$pkgdir" dist/*.whl