summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMarco Rubin2024-05-14 23:12:29 +0200
committerMarco Rubin2024-05-14 23:12:29 +0200
commitf1aedc3eebb63e606f345218c7769c913b12f1f3 (patch)
treebb1b3f1a1fb5d38517f3c62e69eed483087f5c8f /PKGBUILD
parent848f50e17d4d8ca2b78bd3ec26ffce9febf22a1e (diff)
downloadaur-python-qmsolve.tar.gz
2.0.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 4 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index da7582e84dd0..cd847acdd147 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,16 +7,14 @@ pkgrel=1
pkgdesc="A module for solving and visualizing the Schrödinger equation"
arch=("any")
url="https://github.com/quantum-visualizations/qmsolve"
-license=("BSD")
+license=("BSD-3-Clause")
depends=(python-h5py python-matplotlib python-numpy python-progressbar python-scipy)
makedepends=(python-build python-installer python-setuptools python-wheel)
optdepends=('mayavi: for 3D graphics'
'python-pyqt5: for 3D graphics'
'vtk: for 3D graphics')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz"
- "$url/blob/main/LICENSE")
-b2sums=('298ba828761b8646f9ab46aba0ea67d5fc80a5faa70d461407f744a3f3b88cdacb62983809f3ba52f46f3a4ffc30952321f121c4161a1b0b049f95e6c39c09ea'
- '606d6fcdaaf2f75201271870af96e00450564dfed30b0aec0754f94e5f06de2a7a8d00ed40d42947ddf0633f31bc251bac6140981be866b1ae0ab362e6049f4e')
+source=("$url/archive/$pkgver.tar.gz")
+b2sums=('ab7cc38f6a15e1fddc5f0bb234c3a2d72e869a46149639f79945c6f092597c95db62d98fdba43792862f70ec168fd6ce5d355869536c68ff1d80b1a427594a5f')
build() {
cd $_name-$pkgver
@@ -26,5 +24,5 @@ build() {
package() {
cd $_name-$pkgver
python -m installer --destdir="$pkgdir" dist/*.whl
- install -Dm644 ../LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}