summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorwillemw122023-09-22 15:41:00 +0200
committerwillemw122023-09-22 15:41:00 +0200
commit716e46049ebe390e79b7318b7fa363d7f66455bc (patch)
tree4d02b3eebf408841e9865b451ab106354785658a /PKGBUILD
parentda87d9c47577da53173cbac6f1db012cdcd86a6b (diff)
downloadaur-716e46049ebe390e79b7318b7fa363d7f66455bc.tar.gz
Update to standards based install
Update optdepends. Install license file. Add git clean. Minor edits.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 24 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 96f85d1a7e61..81f02ec585bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,40 @@
# Maintainer: willemw <willemw12@gmail.com>
pkgname=python-qtpy-git
-pkgver=1.9.0.r6.g84f0658
+pkgver=2.4.0.r8.g1faf764
pkgrel=1
-pkgdesc="Provides a uniform layer to support PyQt4, PyQt5 and PySide with a single codebase"
-arch=('any')
-url="https://github.com/spyder-ide/qtpy"
-license=('MIT')
-depends=('python-pyqt5')
-makedepends=('git' 'python-setuptools')
-optdepends=('python-pyqt4: Qt-Python bindings'
- 'python-pyside: Qt-Python bindings')
-provides=(${pkgname%-git})
-conflicts=(${pkgname%-git})
+pkgdesc='Provides a uniform layer to support PyQt5 and PySide2 with a single codebase'
+arch=(any)
+url=https://github.com/spyder-ide/qtpy
+license=(MIT)
+depends=(python-pyqt5)
+makedepends=(git python-build python-installer python-wheel python-setuptools)
+optdepends=('python-pyqt5: Qt5 Python bindings'
+ 'python-pyqt6: Qt6 Python bindings'
+ 'python-pyqt5-webengine: Qt5-WebEngine python bindings'
+ 'python-pyqt6-webengine: Qt6-WebEngine python bindings'
+ 'pyside2: PySide Qt5 Python bindings'
+ 'pyside6: PySide Qt6 Python bindings')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
source=($pkgname::git+$url.git)
md5sums=('SKIP')
pkgver() {
- cd $pkgname
- git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
-}
+ git -C $pkgname describe --long --abbrev=7 | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ git -C $pkgname clean -dfx
+}
build() {
cd $pkgname
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd $pkgname
- python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dm644 LICENSE.txt -t "$pkgdir/usr/share/licenses/{pkgname%-git}"
}
-