summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorclintval2018-01-21 18:31:53 -0800
committerclintval2018-01-21 18:31:53 -0800
commit9946a2f645d461373988f403f82d76015a6e6fa3 (patch)
tree7edd33a079b1ad3e65230295d16cc4540e71ad25 /PKGBUILD
downloadaur-9946a2f645d461373988f403f82d76015a6e6fa3.tar.gz
First commit with PKGBUILD and .SRCINFO
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cc9d67b117c3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Clint Valentine <valentine.clint@gmail.com>
+
+_name=rabaDB
+pkgbase='python-rabadb'
+pkgname=('python-rabadb' 'python2-rabadb')
+pkgver=1.0.5
+pkgrel=2
+pkgdesc="Lightweight uncomplicated schemaless ORM on top of sqlite3 for Python"
+arch=('any')
+url=https://pypi.python.org/pypi/"${_name}"
+license=('Apache')
+makedepends=(
+ 'python' 'python-setuptools'
+ 'python2' 'python2-setuptools')
+options=(!emptydirs)
+source=("${pkgname}"-"${pkgver}".tar.gz::https://pypi.python.org/packages/11/10/e8397c370efd954209089319b3d842a1689499a5b5c20812e5094d32b83f/rabaDB-1.0.5.tar.gz)
+sha256sums=('e447a93b6bf22479766ee73533416a30cd6859644854e50c3030285a3d009498')
+
+prepare() {
+ cp -a "${_name}"-"${pkgver}"{,-py2}
+}
+
+build(){
+ cd "${srcdir}"/"${_name}"-"${pkgver}"
+ python setup.py build
+
+ cd "${srcdir}"/"${_name}"-"${pkgver}"-py2
+ python2 setup.py build
+}
+
+package_python2-rabadb() {
+ depends=('python2')
+
+ cd "${_name}"-"${pkgver}"-py2
+ python2 setup.py install --root="${pkgdir}"/ --optimize=1 --skip-build
+}
+
+package_python-rabadb() {
+ depends=('python')
+
+ cd "${_name}"-"${pkgver}"
+ python setup.py install --root="${pkgdir}"/ --optimize=1 --skip-build
+}