summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPekka Ristola2022-04-15 14:55:25 +0300
committerPekka Ristola2022-04-15 14:55:25 +0300
commitbcab40578fde10de6c0de8ee482d42ce2ee8a680 (patch)
treebb0b8a26cb534d48227e9c0c25be7180318b8d65 /PKGBUILD
parent48c98a3f6050cf9d70948a9cb3138ed418e59729 (diff)
downloadaur-bcab40578fde10de6c0de8ee482d42ce2ee8a680.tar.gz
Update to v2.0.9
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 56d47bbc2690..6e7ae052a2c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname='rapidfuzz'
pkgname="python-${_pkgname}"
-pkgver=2.0.7
+pkgver=2.0.9
pkgrel=1
pkgdesc='Rapid fuzzy string matching in Python and C++ using the Levenshtein Distance'
arch=('x86_64')
@@ -18,19 +18,21 @@ makedepends=(
)
optdepends=('python-numpy')
source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
-sha256sums=('93bf42784fd74ebf1a8e89ca1596e9bea7f3ac4a61b825ecc6eb2d9893ad6844')
+sha256sums=('c5ac9477bc7479799ef81d5bb02e657503eda5241490fd6f632a8db5e4a29639')
build() {
cd "${_pkgname}-${pkgver}"
python setup.py build \
-G "Unix Makefiles" \
--build-type None \
- -DCMAKE_CXX_FLAGS_INIT=-fmacro-prefix-map="$srcdir"=. # remove references to srcdir
+ -DCMAKE_CXX_FLAGS_INIT=-fmacro-prefix-map="${srcdir@Q}"=. # remove references to srcdir
}
package() {
cd "${_pkgname}-${pkgver}"
python setup.py --skip-cmake install --root="$pkgdir" --optimize=1 --skip-build
+ # remove unnecessary files (upstream issue #201)
+ rm -r "$pkgdir/usr/include"
install -Dvm644 'README.md' -t "${pkgdir}/usr/share/doc/${pkgname}"
install -Dvm644 'LICENSE' -t "${pkgdir}/usr/share/licenses/${pkgname}"