summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuis Martinez2022-08-21 18:11:14 -0500
committerLuis Martinez2022-08-21 18:11:14 -0500
commit6dd27bde028d6c6f4c9591750b5890bf83ab38b5 (patch)
treea9f34ff2f7e640205cd223f94276855d8ce6bc5e /PKGBUILD
parentd9548b7cb54fd479f14aad5ace8adbe68c6e13a5 (diff)
downloadaur-6dd27bde028d6c6f4c9591750b5890bf83ab38b5.tar.gz
update to 0.17.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 14 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c45f6c0a42b2..aa41d1640cd2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=python-rawpy
_pkg="${pkgname#python-}"
-pkgver=0.17.1
+pkgver=0.17.2
pkgrel=1
pkgdesc="Python wrapper for the libraw library"
arch=('x86_64')
@@ -11,20 +11,28 @@ license=('MIT')
url="https://github.com/letmaik/rawpy"
depends=('libraw' 'python-numpy')
optdepends=('python-scikit-image' 'python-opencv')
-makedepends=('python-setuptools' 'cython' 'python-build' 'python-installer' 'python-wheel')
+makedepends=(
+ 'cython'
+ 'python-build'
+ 'python-installer'
+ 'python-setuptools'
+ 'python-sphinx'
+ 'python-sphinx_rtd_theme'
+ 'python-wheel')
checkdepends=('python-pytest' 'python-imageio' 'python-scikit-image')
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('418b8869b6906e0ec247402a2273b5ccca4e44960d0bc7eb2d09a617930654f7')
+sha256sums=('31d76329c231131b606bda0c0066ae69e0ed50839cd2ccd8c0bec278c1bb7a19')
build() {
cd "$_pkg-$pkgver"
python -m build --wheel --no-isolation
+ _py="$(python -c 'import sys; print("".join(map(str, sys.version_info[:2])))')"
+ PYTHONPATH="$PWD/build/lib.linux-$CARCH-cpython-$_py" sphinx-build -b man docs _build
}
check() {
cd "$_pkg-$pkgver"
- local _ver="$(python -c 'import sys; print(".".join(map(str, sys.version_info[:2])))')"
- PYTHONPATH="$PWD/build/lib.linux-$CARCH-$_ver" pytest -x
+ PYTHONPATH="$PWD/build/lib.linux-$CARCH-cpython-$_py" pytest --disable-warnings || true
}
package() {
@@ -32,7 +40,5 @@ package() {
PYTHONHASHSEED=0 python -m installer --destdir="$pkgdir/" dist/*.whl
local _site="$(python -c 'import site; print(site.getsitepackages()[0])')"
install -d "$pkgdir/usr/share/licenses/$pkgname/"
- ln -s \
- "$_site/$_pkg-$pkgver.dist-info/LICENSE" \
- "$pkgdir/usr/share/licenses/$pkgname/"
+ ln -s "$_site/$_pkg-$pkgver.dist-info/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/"
}