summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoracxz2020-10-05 18:23:38 -0400
committeracxz2020-10-05 18:23:38 -0400
commit811f231407ed3824d33bdaa7f86088450fbe06d5 (patch)
tree7574605bea947083416810dad2bc5eb875f0e996 /PKGBUILD
parente9404df7cf6ca7e555e7dd3bedb72f07769090aa (diff)
downloadaur-811f231407ed3824d33bdaa7f86088450fbe06d5.tar.gz
updpkg 1.0.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8bd731553336..45330117fa16 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,23 @@
# Maintainer: acxz <akashpatel2008 at yahoo dot com>
pkgname=python-ray
-pkgver=0.8.7
+pkgver=1.0.0
pkgrel=1
pkgdesc='A fast and simple framework for building and running distributed
applications.'
arch=('x86_64')
url='https://ray.io'
license=('Apache-2.0')
-depends=(psmisc python python-aiohttp python-aioredis python-click
- python-colorama python-colorful python-filelock python-google
- python-gpustat python-grpcio python-jsonschema python-msgpack
- python-numpy python-protobuf py-spy python-pyaml python-requests
- python-redis python-opencensus python-prometheus-client)
+depends=(psmisc python python-aiohttp python-aiohttp-cors python-aioredis
+ python-click python-colorama python-colorful python-filelock
+ python-google python-gpustat python-grpcio python-jsonschema
+ python-msgpack python-numpy python-protobuf py-spy python-pyaml
+ python-requests python-redis python-opencensus python-prometheus-client)
optdepends=(
'uvicorn: for ray[serve] module'
'python-flask: for ray[serve] module'
- 'python-blist: for ray[serve] module'
+ 'python-pydantic: for ray[serve] module'
+ 'python-dataclasses: for ray[serve] and ray[tune] and ray[rllib] module'
'python-tabulate: for ray[tune] and ray[rllib] module'
'python-tensorboardx: for ray[tune] and ray[rllib] module'
'python-pandas: for ray[tune] and ray[rllib] module'
@@ -31,7 +32,7 @@ optdepends=(
makedepends=(python python-setuptools python-wheel python-pip cython bazel)
_pkgname=ray
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/ray-project/ray/archive/${_pkgname}-$pkgver.tar.gz")
-sha256sums=('2df328f1bcd3eeb4fa33119142ea0d669396f4ab2a3e78db90178757aa61534b')
+sha256sums=('53aa83f6cc020a84d56192d4f4678e192a58ce33f12c5996343949d28780a788')
build() {
cd "${srcdir}/${_pkgname}-${_pkgname}-${pkgver}/python"