summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoracxz2022-05-24 16:17:41 -0400
committeracxz2022-05-24 16:17:41 -0400
commit8df74673786cad92534acbeac0bfafce2f062610 (patch)
tree74b5deb041676b086b53a532f60e403eff3f39ff /PKGBUILD
parent36d46d4f49ce13b7e5ab7f8a644425d07303f6d7 (diff)
downloadaur-8df74673786cad92534acbeac0bfafce2f062610.tar.gz
upgpkg: python-ray 1.12.1-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c9420915f2c1..9cd530703b0d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: acxz <akashpatel2008 at yahoo dot com>
pkgname=python-ray
-pkgver=1.12.0
+pkgver=1.12.1
pkgrel=1
pkgdesc='A fast and simple framework for building and running distributed
applications.'
@@ -49,13 +49,18 @@ optdepends=(
makedepends=(python python-setuptools python-wheel python-pip cython bazel)
_pkgname=ray
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/ray-project/ray/archive/${_pkgname}-$pkgver.tar.gz"
+ "init_order.patch"::"https://github.com/ray-project/ray/commit/85fe5346c83233af8e3aa36a3a9e3001a05f972f.patch"
"py310.patch"::"https://patch-diff.githubusercontent.com/raw/ray-project/ray/pull/21221.patch")
-sha256sums=('f358a942c35890c8939706ef0362569bcd3aca225109b6875492c4832caf2fe7'
+
+sha256sums=('e88933aa912c5165bc3705439608dbf3c3a6c6df8a3299a9a90432bc30340d52'
+ '539f9881e686281a71ca72d3a9a62c926960f400e36f3007d2bb8079b59fd07b'
'SKIP')
prepare() {
cd "${srcdir}/${_pkgname}-${_pkgname}-${pkgver}"
+ patch --strip=1 < "${srcdir}/init_order.patch"
+
#patch --strip=1 < "${srcdir}/py310.patch"
sed -i "s/9)]/9), (3, 10)]/" python/setup.py