summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormschubert2020-04-25 21:55:25 +0200
committermschubert2020-04-25 21:55:25 +0200
commit5a8e82b4944aae7941b5f553dbea21370736850d (patch)
tree9592d38417d09902f642b222947c41c42980fbb8 /PKGBUILD
parent752259f16af9eaf4f04fb3b28c54d062a9f5c3a6 (diff)
downloadaur-5a8e82b4944aae7941b5f553dbea21370736850d.tar.gz
version bump 0.3.24
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dc9cae37d39f..33240aa3820e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Michael Schubert <mschu.dev at gmail>
pkgname=(python-rchitect python2-rchitect)
_pkgname=${pkgname#python-}
-pkgver=0.3.19
+pkgver=0.3.24
pkgrel=1
pkgdesc="Minimal R API for Python"
url="https://github.com/randy3k/$_pkgname"
@@ -11,7 +11,7 @@ makedepends=('python-setuptools' 'python2-setuptools'
'python-six>=1.9.0' 'python2-six>=1.9.0')
checkdepends=('python2-pytest' 'python-pytest')
source=("$_pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('fbea6df9bb071bac184ae78d897650794689c441f65d1b5313b14484c1f2d34c')
+sha256sums=('5f705cd189d280d6ea21bc755c6f1d92b034849abfeed9861ba552a0a1d25975')
check_disabled() { # unnamed error
cd "$srcdir/$_pkgname-$pkgver"
@@ -20,7 +20,7 @@ check_disabled() { # unnamed error
}
package_python-rchitect() {
- depends=('r>3.4.0' 'python-multipledispatch' 'python-cffi')
+ depends=('r>3.4.0' 'python-multipledispatch' 'python-cffi>=1.10.0')
replaces=('python-rapi')
cd "$srcdir/$_pkgname-$pkgver"
@@ -28,7 +28,7 @@ package_python-rchitect() {
}
package_python2-rchitect() {
- depends=('r>3.4.0' 'python2-multipledispatch' 'python2-cffi')
+ depends=('r>3.4.0' 'python2-multipledispatch' 'python2-cffi>=1.10.0')
cd "$srcdir/$_pkgname-$pkgver"
python2 setup.py install --prefix=/usr --root="$pkgdir" --optimize=1