summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSébastien Leduc2015-09-20 10:15:50 +0200
committerSébastien Leduc2015-09-20 10:15:50 +0200
commitef01f70de39b43592a37e4505e4ccbbf2d44e759 (patch)
treedd2b4e017c2868fd68effc5106c7dc44c681b398 /PKGBUILD
downloadaur-ef01f70de39b43592a37e4505e4ccbbf2d44e759.tar.gz
First commit: python-redmine 1.2.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..800efb7ee479
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Sebastien Leduc <sebastien@sleduc.fr>
+pkgname=('python-redmine' 'python2-redmine')
+pkgbase='python-redmine'
+pkgver=1.2.0
+pkgrel=1
+pkgdesc="Python library for communicating with a Redmine project management application"
+arch=("any")
+url="http://python-redmine.readthedocs.org/"
+license=('Apache')
+makedepends=('python' 'python2')
+options=(!emptydirs)
+source=("https://pypi.python.org/packages/source/p/${pkgbase}/${pkgbase}-${pkgver}.tar.gz")
+md5sums=('ca13072692dc5068bd17d47ca83621b9')
+
+prepare() {
+ cp -a "${srcdir}/${pkgbase}-${pkgver}"{,-python2}
+}
+
+package_python-redmine() {
+ depends=('python' 'python-requests')
+ cd "$srcdir/$pkgbase-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+package_python2-redmine() {
+ depends=('python2' 'python2-requests')
+ cd "$srcdir/$pkgbase-$pkgver-python2"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: