summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDesmond Kabus2020-07-10 12:42:32 +0200
committerDesmond Kabus2020-07-10 12:42:32 +0200
commit316aa529d6dad655aa90abfa46bd20b9870297a8 (patch)
treecd03ad361391ebf99ca826c3e44a1bbebf279974 /PKGBUILD
downloadaur-316aa529d6dad655aa90abfa46bd20b9870297a8.tar.gz
Create PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6257b5aa26a5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Desmond Kabus <desmond.kabus@protonmail.com>
+
+pkgbase=python-remind-git
+pkgname=python-remind-git
+_module='remind'
+pkgver=v0.14.0.r25.g77b2916
+pkgrel=1
+pkgdesc="Remind Python library"
+url="https://github.com/jspricke/python-remind"
+depends=('remind' 'python' 'python-dateutil' 'python-pytz' 'python-tzlocal' 'python-vobject')
+makedepends=('python-setuptools')
+checkdepends=('python-coverage' 'python-nose')
+provides=('python-remind')
+conflicts=('python-remind')
+license=('GPL')
+arch=('any')
+source=("remind::git+https://github.com/jspricke/python-remind")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_module}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+check(){
+ cd "${srcdir}/${_module}"
+ nosetests
+}
+
+build() {
+ cd "${srcdir}/${_module}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_module}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}