summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorUniversebenzene2022-09-03 15:20:58 +0800
committerUniversebenzene2022-09-03 15:20:58 +0800
commit39e60878017e6af2bf64d4363f5941a08cae19c8 (patch)
tree449c9fdb5ccc3ede645ceed527ea112253c8032c /PKGBUILD
parent4e226b1a1b66ad294321443c55603ef9b684cf0b (diff)
downloadaur-39e60878017e6af2bf64d4363f5941a08cae19c8.tar.gz
Update to version 0.9
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD49
1 files changed, 39 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6fc62611b515..2c85160f9ab0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,67 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
+
pkgbase=python-reproject
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}" "python-${_pyname}-doc")
-pkgver=0.8
+pkgver=0.9
pkgrel=1
pkgdesc="Python-based Astronomical image reprojection"
arch=('i686' 'x86_64')
url="http://reproject.readthedocs.io"
license=('BSD')
-makedepends=('cython' 'python-setuptools-scm' 'python-extension-helpers' 'python-sphinx-astropy' 'python-astropy-healpix' 'python-pyvo' 'python-mimeparse')
-checkdepends=('python-shapely' 'python-pytest-astropy' 'python-scipy')
+makedepends=('cython'
+ 'python-setuptools-scm'
+ 'python-extension-helpers'
+ 'python-wheel'
+ 'python-build'
+ 'python-installer'
+ 'python-sphinx-astropy'
+ 'python-astropy-healpix'
+ 'python-scipy'
+ 'python-pyvo')
+# 'python-mimeparse') # numpy for package itself
+checkdepends=('python-pytest-arraydiff'
+ 'python-pytest-astropy-header'
+ 'python-pytest-doctestplus'
+ 'python-matplotlib'
+ 'python-sunpy'
+ 'python-gwcs'
+ 'python-shapely') # astropy-healpix scipy already in makedep
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('b7db39086abc683c2b5cfc9b2185736c')
+md5sums=('7ca84f61b5185e58c8dced85bae84356')
+
+get_pyver() {
+ python -c "import sys; print('$1'.join(map(str, sys.version_info[:2])))"
+}
prepare() {
- export _pyver=$(python -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+ cd ${srcdir}/${_pyname}-${pkgver}
+
+ sed -i -e "/cython/s/==/>=/" -e "/oldest-supported-numpy/d" pyproject.toml
+# sed -i "/NaNs/a \ ignore:Subclassing validator classes is not intended:DeprecationWarning" setup.cfg
}
build() {
cd ${srcdir}/${_pyname}-${pkgver}
- python setup.py build
+ python -m build --wheel --no-isolation
msg "Building Docs"
cd ${srcdir}/${_pyname}-${pkgver}/docs
- PYTHONPATH="../build/lib.linux-${CARCH}-${_pyver}" make html
+ PYTHONPATH="../build/lib.linux-${CARCH}-cpython-$(get_pyver)" make html
}
check() {
cd ${srcdir}/${_pyname}-${pkgver}
- pytest "build/lib.linux-${CARCH}-${_pyver}" || warning "Tests failed"
+ pytest "build/lib.linux-${CARCH}-cpython-$(get_pyver)" || warning "Tests failed"
}
package_python-reproject() {
- depends=('python>=3.7' 'python-numpy>=1.14' 'python-scipy>=1.1' 'python-astropy>=3.2' 'python-astropy-healpix>=0.6')
+ depends=('python>=3.8'
+ 'python-numpy>=1.17'
+ 'python-scipy>=1.3'
+ 'python-astropy>=4.0'
+ 'python-astropy-healpix>=0.6')
optdepends=('python-shapely>=1.6: For some of the mosaicking functionality'
'python-reproject-doc: Documentation for Reproject'
'python-pytest-astropy: For testing')
@@ -41,11 +69,12 @@ package_python-reproject() {
install -D -m644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
install -D -m644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
- python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
+ python -m installer --destdir="${pkgdir}" dist/*.whl
}
package_python-reproject-doc() {
pkgdesc="Documentation for Python Reproject module"
+ arch=('any')
cd ${srcdir}/${_pyname}-${pkgver}/docs/_build
install -D -m644 -t "${pkgdir}/usr/share/licenses/${pkgname}" ../../LICENSE