summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhilipp A2021-08-11 11:40:14 +0200
committerPhilipp A2021-08-11 11:40:14 +0200
commit0be4cd529e6942db9d0044ca4e0fbe74273ed3f4 (patch)
tree13bac038fc686f738ee039f9ab2befa82681f341 /PKGBUILD
parent6e32e6892cd8a60eebdc76f5130e55403d311119 (diff)
downloadaur-0be4cd529e6942db9d0044ca4e0fbe74273ed3f4.tar.gz
v0.7.3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 19 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index aea06740e37e..266784aa4764 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,31 @@
-# Maintainer: Simon Legner <Simon.Legner@gmail.com>
+# Maintainer: Phil A. <flying-sheep@web.de>
+# Contributor: Simon Legner <Simon.Legner@gmail.com>
# Contributor: Aniket Pradhan <aniket17133[at]iiitd[dot]ac[dot]in>
# Contributor: Roman Haritonov <reclosedev[at]gmail[dot]com>
-_pkgname="requests-cache"
-pkgname="python-requests-cache"
-pkgver=0.6.4
+_pkgname=requests-cache
+pkgname=python-requests-cache
+pkgver=0.7.3
pkgrel=1
-pkgdesc="Transparent persistent cache for http://python-requests.org/ library."
-arch=("x86_64")
-url="https://github.com/reclosedev/requests-cache"
-license=("BSD")
-depends=("python" "python-requests")
-makedepends=("git" "python-setuptools")
-provides=("python-requests-cache")
-conflicts=("python2-requests-cache")
+pkgdesc='Transparent persistent cache for http://python-requests.org/ library.'
+arch=(x86_64)
+url="https://github.com/reclosedev/$_pkgname"
+license=(BSD)
+depends=(python python-requests)
+makedepends=(git python-setuptools)
+conflicts=(python2-requests-cache)
source=("https://files.pythonhosted.org/packages/source/r/$_pkgname/$_pkgname-$pkgver.tar.gz")
-sha256sums=('dd9120a4ab7b8128cba9b6b120d8b5560d566a3cd0f828cced3d3fd60a42ec40')
+sha256sums=('d17c95b0fa52670044356378886dbaf8e25069123d4fced43e05cd13b38c42f8')
build() {
- cd "$srcdir/$_pkgname-${pkgver}"
- python setup.py build
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py build
}
package() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
- install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -Dm 644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README"
+ install -Dm 644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm 644 README.md "$pkgdir/usr/share/doc/$pkgname/README"
}