summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhilipp A2022-02-24 10:37:21 +0100
committerPhilipp A2022-02-24 10:37:21 +0100
commit23c24d5d7615142124e8d755921ea02921533a3f (patch)
tree8c77813368bf6af5e1e3cfda87f29cf742a4e0e5 /PKGBUILD
parent378d0a5dca98718678ee016593aa13d6f01c1d46 (diff)
downloadaur-23c24d5d7615142124e8d755921ea02921533a3f.tar.gz
switch to python-installer
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 861d6b32b7b4..f424dadc9bfb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,12 +9,12 @@ _base=requests-cache
pkgname=python-${_base}
pkgdesc="Transparent persistent cache for http://python-requests.org library"
pkgver=0.9.3
-pkgrel=1
+pkgrel=2
arch=(any)
url="https://github.com/reclosedev/${_base}"
license=('custom:BSD-2-clause')
depends=(python-requests python-appdirs python-cattrs python-url-normalize)
-makedepends=(python-build python-install python-poetry-core)
+makedepends=(python-build python-installer python-poetry-core)
optdepends=('python-boto3: Cache backend for Amazon DynamoDB database'
'python-botocore: Interface for Amazon Web Services'
'python-pymongo: Cache backend for MongoDB database'
@@ -43,6 +43,6 @@ check() {
package() {
cd ${_base}-${pkgver}
- python -m install --optimize=1 --destdir="${pkgdir}" dist/*.whl
+ python -m installer --destdir="${pkgdir}" dist/*.whl
install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}