summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-08-22 23:36:29 -0500
committerCarlos Aznarán Laos2022-08-22 23:36:29 -0500
commit3c42ba06e215784adeb1184fcff5d62012cb8328 (patch)
treedbe09105a569068c162692d833af19e5fedb9ab5 /PKGBUILD
parent00c10cb1b9d1e259fd704dd83c44b8c76f37a819 (diff)
downloadaur-3c42ba06e215784adeb1184fcff5d62012cb8328.tar.gz
Enable tests and add python-appdirs as checkdependency
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index eabcb79d71fe..a085eaa18600 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ _base=requests-cache
pkgname=python-${_base}
pkgdesc="Transparent persistent cache for http://python-requests.org library"
pkgver=0.9.5
-pkgrel=1
+pkgrel=2
arch=(any)
url="https://github.com/reclosedev/${_base}"
license=('custom:BSD-2-clause')
@@ -23,7 +23,7 @@ optdepends=('python-boto3: Cache backend for Amazon DynamoDB database'
'python-itsdangerous: for pass trusted data to untrusted environments'
'python-yaml: for bindings yaml support'
'python-ujson: for JSON serializer for improved performance')
-# checkdepends=(python-pytest python-requests-mock python-responses python-itsdangerous python-ujson python-timeout-decorator)
+checkdepends=(python-pytest python-requests-mock python-responses python-itsdangerous python-ujson python-timeout-decorator python-appdirs)
source=(${_base}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
sha512sums=('de1481ff609f3ff36ed662d986fb86a500a8d26755832478a9a4396f2c71934b5f65540137b92365eb36f66087b3fbc1cd72c63d37546d09c86bbee7340fd8eb')
@@ -35,11 +35,11 @@ build() {
GIT_CEILING_DIRECTORIES="${PWD}/.." python -m build --wheel --skip-dependency-check --no-isolation
}
-# check() {
-# cd ${_base}-${pkgver}
-# # https://bugs.archlinux.org/task/75188
-# python -m pytest --ignore=tests/integration
-# }
+check() {
+ cd ${_base}-${pkgver}
+ # https://bugs.archlinux.org/task/75188
+ python -m pytest --ignore=tests/integration
+}
package() {
cd ${_base}-${pkgver}