summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-08-24 19:27:38 -0500
committerCarlos Aznarán Laos2022-08-24 19:27:38 -0500
commit4a667528e977db133bc9e8e4015fce4cb3c9d27e (patch)
tree73755781b08654a9f985fa9d023481dbb418f50d /PKGBUILD
parent8c5f11113ab7df1454b0c47062b4a1d484f8e53e (diff)
downloadaur-4a667528e977db133bc9e8e4015fce4cb3c9d27e.tar.gz
Add missing dependency
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 78500df731f2..3b5497f07e72 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,13 +7,13 @@
# Contributor: Roman Haritonov <reclosedev[at]gmail[dot]com>
_base=requests-cache
pkgname=python-${_base}
-pkgdesc="Transparent persistent cache for http://python-requests.org library"
+pkgdesc="A transparent persistent cache for the requests library"
pkgver=0.9.6
pkgrel=1
arch=(any)
url="https://github.com/reclosedev/${_base}"
license=('custom:BSD-2-clause')
-depends=(python-requests python-platformdirs python-cattrs python-url-normalize python-exceptiongroup)
+depends=(python-requests python-appdirs python-cattrs python-url-normalize)
makedepends=(python-build python-installer python-poetry-core)
optdepends=('python-boto3: Cache backend for Amazon DynamoDB database'
'python-botocore: Interface for Amazon Web Services'
@@ -23,7 +23,7 @@ optdepends=('python-boto3: Cache backend for Amazon DynamoDB database'
'python-itsdangerous: for pass trusted data to untrusted environments'
'python-yaml: for bindings yaml support'
'python-ujson: for JSON serializer for improved performance')
-checkdepends=(python-pytest python-requests-mock python-responses python-itsdangerous python-ujson python-timeout-decorator python-appdirs)
+checkdepends=(python-pytest python-requests-mock python-responses python-itsdangerous python-ujson python-timeout-decorator)
source=(${_base}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
sha512sums=('88e4745bed278224ccd1eb815a4f9da84051bab79c43122fa97899c3a8ad87ad7bfd929f87680eb6f73b1ff14267d2519afd9ef8815f10597769cab8ada7f8b5')