summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-01-01 13:42:09 -0500
committerCarlos Aznarán Laos2022-01-01 13:42:09 -0500
commite773447ce1018d181dee160265e31ca07abc24c3 (patch)
tree50588ba2d5634e71ce0d33ca42e9d20c4e8a2cfe /PKGBUILD
parentccc2403e9394898d53dbd809c7602898129151d0 (diff)
downloadaur-e773447ce1018d181dee160265e31ca07abc24c3.tar.gz
Version bump to 0.9.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3152dd657687..e285aa4d838e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,19 +8,24 @@
_base=requests-cache
pkgname=python-${_base}
pkgdesc="Transparent persistent cache for http://python-requests.org library"
-pkgver=0.8.1
-pkgrel=4
+pkgver=0.9.0
+pkgrel=1
arch=('any')
url="https://github.com/reclosedev/${_base}"
license=('custom:BSD-2-clause')
-depends=(python-requests python-url-normalize python-cattrs python-appdirs)
+depends=(python-requests python-appdirs python-cattrs python-url-normalize)
makedepends=(python-build python-install python-poetry)
optdepends=('python-boto3: Cache backend for Amazon DynamoDB database'
+ 'python-botocore: Interface for Amazon Web Services'
+ 'python-pymongo: Cache backend for MongoDB database'
'python-redis: Cache backend for Redis cache'
- 'python-pymongo: Cache backend for MongoDB database')
+ 'python-bson: for BSON codec'
+ 'python-itsdangerous: for pass trusted data to untrusted environments'
+ 'python-yaml: for bindings yaml support'
+ 'python-ujson: for JSON serializer for improved performance')
checkdepends=(python-pytest python-requests-mock python-responses python-itsdangerous python-ujson python-timeout-decorator)
source=(${_base}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
-sha512sums=('245ee7059afab50f32af9c8831fe11c14d5bd53fe6bbf02e5844974e0e5ea6c33e005f234485f245ee418ae03277c6e2cc41046a385ff138e58785cf37b119ea')
+sha512sums=('1f4879ddae34a10f014deb31c62fbe18c3d6a30ea10823d122aec4920ea4024eaf86c0b1a6f369b71f827ee87f049a5c2dad9fabe61aa6a5a62093fb08fa4a7c')
build() {
cd "${_base}-${pkgver}"