summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcaltlgin2020-12-03 09:26:23 +1300
committercaltlgin2020-12-03 09:26:23 +1300
commit931426b8f90b9e69de9dbf347ae9e8234507b6d7 (patch)
treeb315819df6ee2a1c52350ed77088c86b5cca1a8a /PKGBUILD
parenteab1349a6f410ec5667683dfb0890dceced76cb6 (diff)
downloadaur-931426b8f90b9e69de9dbf347ae9e8234507b6d7.tar.gz
Python 3.9 rebuild
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 02dd9f2c8c02..eed6f013036b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,17 @@
# Contributor: Chih-Hsuan Yen <yan12125@gmail.com>
# Contributor: Alexander 'z33ky' Hirsch <1zeeky@gmail.com>
-_pkgname=requests-futures
+_pkgname='requests-futures'
pkgname="python-${_pkgname}"
pkgver=1.0.0
-pkgrel=1
+pkgrel=2
pkgdesc='Asynchronous Python HTTP Requests for Humans'
arch=('any')
url='https://github.com/ross/requests-futures'
+_url_pypi='https://pypi.org/project/requests-futures'
license=('APACHE')
-depends=('python' 'python-requests')
+depends=('python-requests')
makedepends=('python-setuptools')
-provides=("${pkgname}")
source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
sha256sums=('35547502bf1958044716a03a2f47092a89efe8f9789ab0c4c528d9c9c30bc148')
@@ -24,7 +24,7 @@ build() {
package() {
cd "${_pkgname}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
- install -Dm644 -t "${pkgdir}/usr/share/doc/${_pkgname}" 'README.rst'
+ install -Dvm644 'README.rst' -t "${pkgdir}/usr/share/doc/${pkgname}"
}
# vim: ts=2 sw=2 et: