summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKokaKiwi2023-06-28 02:04:05 +0200
committerKokaKiwi2023-06-28 02:04:05 +0200
commit7143f8fc88880d21bfcc488dd7dd3ed8980c0b4c (patch)
treefdef10193103dd96fa18cec2b041452ae6af16ea /PKGBUILD
parentc446eba5b62efcb2911c15ba3782b15b16679028 (diff)
downloadaur-7143f8fc88880d21bfcc488dd7dd3ed8980c0b4c.tar.gz
upgpkg: python-returns 0.21.0-1
upstream release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1716503e229d..cba3fa41318c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=returns
pkgname="python-$_pkgname"
-pkgver=0.20.1
+pkgver=0.21.0
pkgrel=1
pkgdesc="Make your functions return something meaningful, typed, and safe"
arch=('any')
@@ -10,10 +10,17 @@ url="https://pypi.org/project/parsita"
license=('MIT')
depends=('python' 'python-typing_extensions')
makedepends=('python-poetry-core' 'python-build' 'python-installer' 'python-wheel')
-checkdepends=('python-pytest' 'python-pytest-mypy-plugins' 'python-pytest-subtests' 'python-pytest-randomly' 'python-hypothesis')
+checkdepends=(
+ 'python-pytest' 'python-pytest-mypy-plugins' 'python-pytest-subtests' 'python-pytest-randomly'
+ 'python-pytest-cov'
+ 'python-hypothesis' 'python-anyio' 'python-httpx' 'python-attrs' 'python-trio'
+)
+optdepends=(
+ 'mypy: For mypy compatibility'
+)
source=("$pkgname-$pkgver.tar.gz::https://github.com/dry-python/returns/archive/refs/tags/$pkgver.tar.gz")
-sha256sums=('8ae4dea988623699f0447f773a3f0a15409d4c96a39d7e3fa2c55c0391de438e')
-b2sums=('89b8399c806380080a0a75c0b6c684a2a28349afcdf356d1a7e35ac3e667b643c9bdc8108fdcadc97bdd8c9981d504c1a35be07ea898be1ec174ce6ca29ef868')
+sha256sums=('2ede3ff7b310740ce97fdb63ad87847b4e7be4f0658d282ee62e1b88ed4c2675')
+b2sums=('ac67bd4e6c867c3be6a1a3d8f610a2558654fbdebd70664f959dc2518eb9d4faff2e07c828bc30dc5bd4c8ea537905e5352a4d866c434039e5c5276b1748e47d')
build() {
cd "$_pkgname-$pkgver"