summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorrazer2020-12-24 07:11:30 +0100
committerrazer2020-12-24 07:11:30 +0100
commitb6f2fca29b58fa8ef85d1893867e64670702b9fe (patch)
treeea8347b8b00c84bff9e58d8535d645b1a8276f83 /PKGBUILD
parenta5640aeb82daa7360c103bf34ecce821375f36fc (diff)
downloadaur-b6f2fca29b58fa8ef85d1893867e64670702b9fe.tar.gz
Patch solving build issue
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4e2dc228c859..b860c27f22fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,21 @@
# Maintainer: Razer <razer[AT]neuf[DOT]fr>
pkgname=python-rf24
pkgver=1.3.9
-pkgrel=1
+pkgrel=2
pkgdesc='Python bindings for RF24 radio modules'
arch=(any)
url='http://tmrh20.github.io/RF24/'
license=('GPL2')
depends=('boost-libs' 'python' 'rf24')
makedepends=('boost' 'python-setuptools')
-source=("https://github.com/nRF24/RF24/archive/v${pkgver}.tar.gz")
-sha256sums=('7fc2d32a3a226faa78e60ba472ad40f3da97d4d158845f9603d41e1cf8f31ae4')
+source=("https://github.com/nRF24/RF24/archive/v${pkgver}.tar.gz" "boost-include.patch")
+sha256sums=('7fc2d32a3a226faa78e60ba472ad40f3da97d4d158845f9603d41e1cf8f31ae4'
+ '80439c7ae3c30c93e8da055b753bbe047da22815041aea048d723afd75ea1a39')
+
+prepare() {
+ cd "$srcdir"
+ patch --forward --strip=1 --input="${srcdir}/boost-include.patch"
+}
build() {
cd "$srcdir/RF24-$pkgver"