summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatheus2016-01-17 15:50:31 -0200
committerMatheus2016-01-17 15:50:31 -0200
commit2e0ebbd907f1983178532517181805a3979b20dc (patch)
treebf5ab774b02aa99e59e9d3c94f23670864f80979 /PKGBUILD
downloadaur-2e0ebbd907f1983178532517181805a3979b20dc.tar.gz
Init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..675b112c9f7c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Trevor <assviolat0r at live dot com>
+pkgname=python-rivescript
+pkgver=1.0
+pkgrel=1
+pkgdesc="Rendering Intelligence Very Easily"
+arch=('any')
+license=('MIT')
+depends=('python2' 'python-six' 'python-setuptools')
+makedepends=('git')
+url='https://github.com/aichaos/rivescript-python'
+source=('git+https://github.com/aichaos/rivescript-python.git')
+md5sums=('SKIP')
+_gitname=rivescript-python
+
+pkgver () {
+ cd $_gitname
+ echo $(git rev-list --count HEAD).$(git describe --always | sed 's/-/./g')
+}
+
+package() {
+ cd "$srcdir/$_gitname" # Git name and $pkgname differs
+ # Do the actual installation
+ python setup.py install
+}