summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatheus2016-01-18 19:39:50 -0200
committerMatheus2016-01-18 19:39:50 -0200
commit95ba29ebd77cd3bfdbf58c1c578eecb628e36908 (patch)
tree91e25e197e0877a5a030b23f68419959e7b3f1f2 /PKGBUILD
parent8df09c975a7856f10acd360753a7d99acd82a8be (diff)
downloadaur-95ba29ebd77cd3bfdbf58c1c578eecb628e36908.tar.gz
Init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0291fb170a90..f31606fdf708 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,12 @@
# Maintainer: Trevor <assviolat0r at live dot com>
+
pkgname=python-rivescript
pkgver=1.0
pkgrel=1
pkgdesc="Rendering Intelligence Very Easily"
arch=('any')
license=('MIT')
-depends=('python2' 'python-six' 'python-setuptools')
+depends=('python2' 'python-six' 'python2-six' 'python-setuptools' 'python2-setuptools')
makedepends=('git')
url='https://github.com/aichaos/rivescript-python'
source=('git+https://github.com/aichaos/rivescript-python.git')
@@ -17,8 +18,11 @@ pkgver () {
echo $(git rev-list --count HEAD).$(git describe --always | sed 's/-/./g')
}
+build() {
+ python setup.py build
+}
+
package() {
- cd "$srcdir/$_gitname" # Git name and $pkgname differs
- # Do the actual installation
- python setup.py install --prefix=/usr --root="$_gitname" || return 1
+ cd "$srcdir/$_gitname"
+ python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 || return 1
}