summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoremersion2018-12-12 14:02:51 +0100
committeremersion2018-12-12 14:02:51 +0100
commit4c9fb9a5bf8b96723fdb76d236b3c2b94a57c446 (patch)
treeac401b337af70059da81805a637aedd3c6643254 /PKGBUILD
downloadaur-4c9fb9a5bf8b96723fdb76d236b3c2b94a57c446.tar.gz
First commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0e4df5404830
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+pkgname=python-robotarium-git
+pkgver=r19.1ed474a
+pkgrel=1
+pkgdesc="A Python-based simulator for the Robotarium."
+url="https://github.com/robotarium/robotarium_python_simulator"
+arch=('x86_64')
+license=('GPL3')
+depends=('python' 'python-cvxopt' 'python-scipy' 'python-numpy' 'python-matplotlib')
+makedepends=('python-setuptools')
+source=('git+https://github.com/robotarium/robotarium_python_simulator.git')
+sha256sums=('SKIP')
+provides=('python-robotarium')
+conflicts=('python-robotarium')
+
+pkgver() {
+ cd "$srcdir"/robotarium_python_simulator
+
+ # Pull the version tag from the file
+ printf "%s" "$(grep -R "__version__ =" autopep8.py | awk -F\' '{print $2}')"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir"/robotarium_python_simulator
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir"/robotarium_python_simulator
+ python setup.py install --root="${pkgdir}" --optimize=1
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+