summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKartik Mohta2020-05-31 11:21:48 -0700
committerKartik Mohta2020-05-31 11:21:48 -0700
commiteab041242a2eee5bb0cfbd93589584d09dd04068 (patch)
tree9aadf1249d283d37e97b10a76943110eb751ee1c /PKGBUILD
parent03fee5b674ae32bb5a4baf8a2d358d41ec1effa4 (diff)
downloadaur-eab041242a2eee5bb0cfbd93589584d09dd04068.tar.gz
Switch source to github repo
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 11 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 159041095590..46bc284d4cae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
# Maintainer: Kartik Mohta <kartikmohta@gmail.com>
-pkgbase='python-rosdistro'
pkgname=('python-rosdistro')
-_module='rosdistro'
pkgver='0.8.2'
-pkgrel=1
-pkgdesc="A tool to work with rosdistro files"
-url="http://wiki.ros.org/rosdistro"
+pkgrel=2
+pkgdesc='A tool to work with rosdistro files'
+arch=('any')
+url='https://github.com/ros-infrastructure/rosdistro'
+license=('BSD')
depends=('python' 'python-catkin_pkg' 'python-rospkg' 'python-yaml')
-conflicts=('python2-rosdistro')
makedepends=('python-setuptools')
-license=('BSD')
-arch=('any')
-source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
-sha256sums=('aa51e08e27e59dfd26c7754dc43fb3e99f897fd9281ff64a86723b264fcbd964')
+
+conflicts=('python2-rosdistro')
+source=("https://github.com/ros-infrastructure/rosdistro/archive/${pkgver}.tar.gz")
+sha256sums=('ca6e7955820658781bde572927895c2ae8d89c37d5d891a254fd9cc29f9904a6')
+
+_module='rosdistro'
build() {
cd "${srcdir}/${_module}-${pkgver}"