summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKevin MacMartin2023-06-19 15:00:22 -0400
committerKevin MacMartin2023-06-19 15:00:22 -0400
commit7507ee918c4370c4ac2f9ff1e841fd00f5de423f (patch)
tree1b2eba7c2f7d61c4ef4fa278dd46e6263c6aef26 /PKGBUILD
downloadaur-7507ee918c4370c4ac2f9ff1e841fd00f5de423f.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5343c15b34ce
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Kevin MacMartin <prurigro at gmail dot com>
+
+_pkgname=rows
+pkgname=python-${_pkgname}-git
+pkgver=v0.4.1.r216.g895e16a
+pkgrel=1
+pkgdesc='Import data, automatically detect types and give you high-level Python objects so you can start working with the data instead of trying to parse it'
+arch=("any")
+url='https://github.com/turicas/rows'
+license=('GPL3')
+depends=('python-cached-property' 'python-click' 'python-lxml' 'python-magic' 'python-openpyxl' 'python-pdfminer' 'python-pillow' 'python-psycopg2' 'python-pytesseract' 'python-requests' 'python-requests-cache' 'python-six' 'python-tqdm' 'python-unicodecsv' 'python-urllib3' 'python-xlrd' 'python-xlwt')
+makedepends=('git' 'python-build' 'python-installer' 'python-setuptools' 'python-wheel')
+source=("git+https://github.com/turicas/rows")
+sha512sums=('SKIP')
+provides=("python-$_pkgname")
+conflicts=("python-$_pkgname")
+
+pkgver() {
+ cd $_pkgname
+ git describe --tags | sed 's|^[^-]*-v||;s|-|.r|;s|-|.|g'
+}
+
+build() {
+ cd $_pkgname
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd $_pkgname
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}