summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorrern2022-06-24 08:04:37 +0700
committerrern2022-06-24 08:04:37 +0700
commit20a9419a0ad230043af906f849c2e64ef813ac19 (patch)
tree9e69fd982beaa11424be2668396ad913d06a8389 /PKGBUILD
parent2559c2934791bb18167ed632448fca200d41c756 (diff)
downloadaur-20a9419a0ad230043af906f849c2e64ef813ac19.tar.gz
change source
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index eb58406a05e4..cbe9665037e7 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# get source: https://sourceforge.net/p/raspberry-gpio-python/code/ci/default/tree/ > Download Snapshot
# mkdir $pkgname-$pkgver
# bsdtar --strip 1 -C $pkgname-$pkgver -xf raspberry-gpio-python*.zip
-# bsdtar -cjf $pkgnamever.tar.xz $pkgname-$pkgver
+# bsdtar -cjf $pkgname-$pkgver.tar.xz $pkgname-$pkgver
pkgname=python-rpi-gpio
@@ -15,11 +15,11 @@ license=(MIT)
arch=(any)
depends=(python)
makedepends=(python python-distribute)
-source=(https://github.com/rern/rern.github.io/releases/download/20210307/$pkgname-$pkgver.tar.xz)
-sha256sums=(c4acb800fea3e256e95b6aa7de152ab7d20f5567954df3016dcef141b33d86bd)
+source=(https://github.com/rern/rern.github.io/raw/main/python-rpi-gpio/$pkgname-$pkgver.tar.xz)
+sha256sums=('2db2b11bd150b9f4779de02fd807681a9acd8a31c1063287eb3bbdfba96227d5')
package() {
- mv -f $srcdir/$pkgname "$srcdir/RPi.GPIO-$pkgver"
+ mv -f $srcdir/$pkgname-$pkgver "$srcdir/RPi.GPIO-$pkgver"
cd "$srcdir/RPi.GPIO-$pkgver"
env CFLAGS="-fcommon" python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
}