summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorrern2022-01-11 16:58:07 +0700
committerrern2022-01-11 16:58:07 +0700
commit41fef0c4de0f323f246b64adb4c40986efffd40f (patch)
tree0a677d27636f3b8692648428cb2e10f3f6fbaacd /PKGBUILD
downloadaur-41fef0c4de0f323f246b64adb4c40986efffd40f.tar.gz
initial upload
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..db8cc4a92773
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Devaev Maxim <mdevaev@gmail.com>
+# Contributor: Michael Serpieri <contact at pygoscelis dot org>
+
+# get pkgurl:
+# - https://sourceforge.net/p/raspberry-gpio-python/code/ci/default/tree/
+# - Download Snapshot > get download link
+pkgurl=https://sourceforge.net/code-snapshots/hg/r/ra/raspberry-gpio-python/code/raspberry-gpio-python-code-08048dd1894a6b09a104557b6eaa6bb68b6baac5.zip
+
+pkgname=python-rpi-gpio
+pkgver=0.7.1a4
+pkgrel=1
+pkgdesc="Python library for GPIO access on a Raspberry Pi"
+url="http://sourceforge.net/projects/raspberry-gpio-python"
+license=(MIT)
+arch=(armv6h armv7h aarch64)
+depends=(python)
+makedepends=(gcc python-distribute)
+source=("$pkgurl")
+sha256sums=(SKIP)
+
+package() {
+ mv -f "$srcdir/$( basename $pkgurl .zip )" "$srcdir/RPi.GPIO-$pkgver"
+ cd "$srcdir/RPi.GPIO-$pkgver"
+ env CFLAGS="-fcommon" python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
+}