summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Arndt2019-04-16 02:09:30 +0200
committerChristopher Arndt2019-04-16 02:09:30 +0200
commit1c949473399ac760398d78c013fd044b4b81b313 (patch)
tree2dc4defc5669c357c06446e5087e7ff4ec736b9c /PKGBUILD
parent3eec65cb37b24d67fa97c43e63768a99c521440c (diff)
parent5c5ccc526e1b568defcb2de261b496f38c4993eb (diff)
downloadaur-1c949473399ac760398d78c013fd044b4b81b313.tar.gz
Merge branch 'master' of ssh://aur.archlinux.org/python-rtmidi
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 1 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c55cfc9e7a17..1d8a12726a6b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ arch=('i686' 'x86_64' 'arm')
url="https://github.com/SpotlightKid/python-rtmidi"
license=('MIT')
depends=('jack')
-makedepends=('python-setuptools' 'python2-setuptools')
+makedepends=('cython' 'cython2' 'python-setuptools' 'python2-setuptools')
source=("https://files.pythonhosted.org/packages/source/${pkgbase::1}/${pkgbase}/${pkgbase}-${pkgver}.tar.gz")
sha256sums=('61e9d1c1f1202a1577f06644948af985427030984ff956970a22b50f080d4c2d')
@@ -29,7 +29,6 @@ build() {
package_python-rtmidi() {
pkgdesc="Python bindings for the cross-platform MIDI I/O library RtMidi"
depends+=('python')
- makedepends+=('cython')
cd "${srcdir}/${pkgbase}-${pkgver}"
python setup.py install --root="$pkgdir" --skip-build --optimize=1
@@ -41,7 +40,6 @@ package_python-rtmidi() {
package_python2-rtmidi() {
pkgdesc="Python 2 bindings for the cross-platform MIDI I/O library RtMidi"
depends+=('python2')
- makedepends+=('cython2')
cd "${srcdir}/python2-${_pkgbase}-$pkgver"
python2 setup.py install --root="$pkgdir" --skip-build --optimize=1