summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Arndt2019-02-07 17:06:54 +0100
committerChristopher Arndt2019-02-07 17:06:54 +0100
commit5c5ccc526e1b568defcb2de261b496f38c4993eb (patch)
treee22da872724bb1a467de73e979bcac286d3a782e /PKGBUILD
parentec24296eb6b14185017579660139cbca0f8fc877 (diff)
downloadaur-5c5ccc526e1b568defcb2de261b496f38c4993eb.tar.gz
Move makedepends out oof package functions
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 2 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6bc1fb8b31c1..f44d42e026a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,12 +4,12 @@ _pkgbase="rtmidi"
pkgbase="python-${_pkgbase}"
pkgname=(${pkgbase} python2-${_pkgbase})
pkgver=1.2.1
-pkgrel=1
+pkgrel=2
arch=('i686' 'x86_64' 'arm')
url="https://github.com/SpotlightKid/python-rtmidi"
license=('MIT')
depends=('jack')
-makedepends=('python-setuptools' 'python2-setuptools')
+makedepends=('cython' 'cython2' 'python-setuptools' 'python2-setuptools')
source=("https://files.pythonhosted.org/packages/source/${pkgbase::1}/${pkgbase}/${pkgbase}-${pkgver}.tar.gz")
sha256sums=('024a7a466c5b97f8fbbbcb2a6c968f10f4344f348a318188c3c0a7ae5f3e1b19')
@@ -29,7 +29,6 @@ build() {
package_python-rtmidi() {
pkgdesc="Python bindings for the cross-platform MIDI I/O library RtMidi"
depends+=('python')
- makedepends+=('cython')
cd "${srcdir}/${pkgbase}-${pkgver}"
python setup.py install --root="$pkgdir" --skip-build --optimize=1
@@ -41,7 +40,6 @@ package_python-rtmidi() {
package_python2-rtmidi() {
pkgdesc="Python 2 bindings for the cross-platform MIDI I/O library RtMidi"
depends+=('python2')
- makedepends+=('cython2')
cd "${srcdir}/python2-${_pkgbase}-$pkgver"
python2 setup.py install --root="$pkgdir" --skip-build --optimize=1