summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Arndt2022-07-08 21:52:49 +0000
committerFlorian Hülsmann2022-07-08 21:52:49 +0000
commitc737b0029c3a926e40748a6d32a824b4abe01cb3 (patch)
tree27ba5dcbd794cd4a14dcdf0158504a3e067c4751 /PKGBUILD
parent3f852818cfae27b398427806aa04e4cb60fe67b6 (diff)
downloadaur-c737b0029c3a926e40748a6d32a824b4abe01cb3.tar.gz
bump some pkgrels to trigger AUR updates and debug builds (#89)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 14 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b9ac274f2c8e..2f0e5dd9b1cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,27 @@
-# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
+# Maintainer: OSAMC <https://github.com/osam-cologne/archlinux-proaudio>
+# Contributor: Christopher Arndt <aur -at- chrisarndt -dot- de>
-pkgname="python-rtmidi"
-pkgdesc="Python bindings for the cross-platform MIDI I/O library RtMidi"
+pkgname=python-rtmidi
+pkgdesc='Python bindings for the cross-platform MIDI I/O library RtMidi'
pkgver=1.4.9
-pkgrel=1
-arch=('i686' 'x86_64' 'arm')
-url="https://github.com/SpotlightKid/python-rtmidi"
-license=('MIT')
-depends=('jack' 'python')
-makedepends=('cython' 'python-setuptools')
+pkgrel=2
+arch=(x86_64 aarch64)
+url='https://github.com/SpotlightKid/python-rtmidi'
+license=(MIT)
+depends=(python)
+makedepends=(alsa-lib cython jack python-setuptools)
source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz")
sha256sums=('bfeb4ed99d0cccf6fa2837566907652ded7adc1c03b69f2160c9de4082301302')
-
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd $pkgname-$pkgver
python setup.py build
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ depends+=(libasound.so libjack.so)
+ cd $pkgname-$pkgver
python setup.py install --root="$pkgdir" --skip-build --optimize=1
-
# license
- install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 LICENSE.txt -t "$pkgdir"/usr/share/licenses/$pkgname
}