summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBen Westover2023-10-25 12:06:45 -0400
committerBen Westover2023-10-25 12:06:45 -0400
commit379bbbbe464c6706243fd1683f40b546d5668b22 (patch)
treeeeb20e45390910f29b6733828f9f1a0667811c0e /PKGBUILD
parent3d45bb46ba5c97aecad5c1a7f6c2749455663b5a (diff)
downloadaur-python-rust2rpm.tar.gz
Update to 25.0.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e7979c44cb89..cb866f5198f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,29 @@
-# Maintainer: Ben Westover <kwestover.kw@gmail.com>
+# Maintainer: Ben Westover <me@benthetechguy.net>
pkgname=python-rust2rpm
-pkgver=21
+pkgver=25.0.1
pkgrel=1
pkgdesc="Tool for automatically generating RPM spec files for Rust crates"
arch=('any')
url="https://pagure.io/fedora-rust/rust2rpm"
license=('MIT')
-depends=('python' 'python-jinja' 'python-requests' 'python-tqdm')
-makedepends=('python-setuptools')
-checkdepends=('python-pytest')
+depends=('python' 'python-cargo2rpm' 'python-jinja' 'python-jsonschema' 'python-pyparsing' 'python-requests' 'python-termcolor' 'python-tqdm' 'rust2rpm-helper')
+makedepends=('python-build' 'python-installer' 'python-wheel' 'python-setuptools')
+checkdepends=('python-pytest' 'python-pytest-cov' 'python-pytest-mypy')
source=("https://pagure.io/fedora-rust/rust2rpm/archive/v${pkgver}/rust2rpm-v${pkgver}.tar.gz")
-sha256sums=('5ecea8fb85ba222dc06e21b65ddbd0a195d79ffa8dfd19224c232c947dcd188c')
+sha256sums=('41db725fa1a1409e0421d273b2b587f0d7c60d80681b230bed806d2a798b528c')
build() {
cd rust2rpm-v$pkgver
- python setup.py build
+ python -m build --wheel --no-isolation
}
check() {
cd rust2rpm-v$pkgver
- pytest test.py
+ PYTHONPATH=. pytest
}
package() {
cd rust2rpm-v$pkgver
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
}