summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBen Westover2021-12-22 01:27:25 -0500
committerBen Westover2021-12-22 01:27:25 -0500
commit3388f7d605997e39f7baa42ca580a3e6f6dd6093 (patch)
treef7e8e69ac29da48fd7f3462bc182abd6b0055573 /PKGBUILD
downloadaur-3388f7d605997e39f7baa42ca580a3e6f6dd6093.tar.gz
Initial Commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..85b89eec2bb7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Ben Westover <kwestover.kw@gmail.com>
+pkgname=python-rust2rpm
+pkgver=20
+pkgrel=1
+pkgdesc="RPM macro/tools/junk for Rust"
+arch=('any')
+url="https://pagure.io/fedora-rust/rust2rpm"
+license=('MIT')
+depends=('python' 'python-jinja' 'python-requests' 'python-tqdm')
+makedepends=('python-setuptools')
+optdepends=('python-pynacl: Voice support'
+ 'libffi: Voice support')
+source=("https://pagure.io/fedora-rust/rust2rpm/archive/v20/rust2rpm-v${pkgver}.tar.gz")
+sha256sums=('fa8b7d8fab5ed5a84a38c6f9f4a468671536e8a8e4e74affaf8f4ba1988b9327')
+
+build() {
+ cd "$srcdir"/rust2rpm-v${pkgver}
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir"/rust2rpm-v${pkgver}
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}