summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndy Botting2017-10-18 09:23:57 +1100
committerAndy Botting2017-10-18 09:23:57 +1100
commit313f6af597c25c065ec3af76602a89c42716b7b9 (patch)
tree9806822bcb0a9615974b17450c51eb6e34d85767 /PKGBUILD
parentd8557d1f7d873b019d1d0531e451d50aa433192e (diff)
downloadaur-313f6af597c25c065ec3af76602a89c42716b7b9.tar.gz
Update to v1.3.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f6995c638bd2..a351caca24d5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Andy Botting <andy@andybotting.com>
pkgname=('python-saharaclient' 'python2-saharaclient')
-pkgver='1.1.0'
-pkgrel='2'
+pkgver='1.3.0'
+pkgrel='1'
pkgdesc='Python client library for Sahara'
arch=('any')
url="http://docs.openstack.org/developer/${pkgname}/"
@@ -19,14 +19,16 @@ checkdepends=('python-pbr' 'python2-pbr'
'python-requests' 'python2-requests'
'python-six' 'python2-six'
'python-mock' 'python2-mock'
+ 'python-pycodestyle' 'python2-pycodestyle'
'python-oslotest' 'python2-oslotest'
- 'python-os-testr' # 'python2-os-testr'
+ 'python-os-testr'
'python-requests-mock' 'python2-requests-mock'
'python-testrepository' 'python2-testrepository')
source=("git+https://git.openstack.org/openstack/${pkgname}#tag=${pkgver}")
md5sums=('SKIP')
prepare() {
+ sed -i 's/pep8/pycodestyle/g' "${srcdir}/${pkgname}/saharaclient/tests/hacking/checks.py"
cp -a "${srcdir}/${pkgname}"{,-py2}
}
@@ -42,8 +44,8 @@ check() {
cd "${srcdir}/${pkgname}"
python setup.py testr
- #cd "${srcdir}/${pkgname}-py2"
- #PYTHON=python2 python2 setup.py testr
+ cd "${srcdir}/${pkgname}-py2"
+ PYTHON=python2 python2 setup.py testr
}
package_python-saharaclient() {