summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcarlwgeorge2017-04-13 21:59:02 -0500
committercarlwgeorge2017-04-13 21:59:02 -0500
commit003c28f260359ac9e0b63785f40be0f9682f87cf (patch)
treee4ee7c35eda20118913d9680c0d461ac421229e9 /PKGBUILD
parent05cce175040c358af13ec7a2fd3022ca14e79830 (diff)
downloadaur-003c28f260359ac9e0b63785f40be0f9682f87cf.tar.gz
0.5.0-1
* add python-websockets dependency
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4044e2c24297..620d459876d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_name="sanic"
pkgname="python-$_name"
-pkgver=0.4.1
+pkgver=0.5.0
pkgrel=1
pkgdesc="A microframework based on uvloop, httptools, and learnings of flask"
arch=("any")
@@ -11,7 +11,7 @@ license=("MIT")
makedepends=("python-setuptools")
source=("https://files.pythonhosted.org/packages/source/${_name:0:1}/$_name/$_name-$pkgver.tar.gz"
"https://raw.githubusercontent.com/channelcat/sanic/$pkgver/LICENSE")
-sha256sums=('b87393002894a539174a0037c0f6293a558ff393d305c20fa07829f1757360a1'
+sha256sums=('594fa5c1d7812a1114b4049a9ff53a167f7d929d4bf05b2e23f5619861e6e747'
'a406579cd136771c705c521db86ca7d60a6f3de7c9b5460e6193a2df27861bde')
build() {
@@ -23,7 +23,8 @@ package() {
depends=("python-uvloop>=0.5.3"
"python-httptools>=0.0.9"
"python-ujson>=1.35"
- "python-aiofiles>=0.3.0")
+ "python-aiofiles>=0.3.0"
+ "python-websockets>=3.2")
cd "$_name-$pkgver"
python setup.py install --skip-build --root="$pkgdir" --optimize=1
install -D --mode 644 --target-directory "$pkgdir/usr/share/licenses/$pkgname" "$srcdir/LICENSE"