summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWil Thomason2021-10-21 15:18:06 -0700
committerWil Thomason2021-10-21 15:18:06 -0700
commit91d16f89527fc5c9bd8a4146c831fc6259546d07 (patch)
tree1f58d93e11c08867ae71ea13b5c2249a5d198a09 /PKGBUILD
parenta6bd785df09d940f87be5ad6de0963b38709435c (diff)
downloadaur-91d16f89527fc5c9bd8a4146c831fc6259546d07.tar.gz
Update dependencies and fix libscalene path
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 14844283b14c..9ef14bdff5a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Wil Thomason <wbthomason at cs dot cornell dot edu>
pkgname='python-scalene-git'
-pkgver=r698.5ba4693
+pkgver=r2002.1fea191
pkgrel=1
pkgdesc='Scalene is a high-performance, high-precision CPU and memory profiler for Python'
arch=('any')
url='https://github.com/emeryberger/scalene'
license=('Apache-2.0')
-depends=('python>=3.6' 'python-numpy' 'python-cloudpickle' 'python-rich')
+depends=('python>=3.7' 'python-numpy' 'python-cloudpickle' 'python-rich' 'python-pynvml')
makedepends=('python-setuptools' 'make' 'clang' 'git')
source=("${pkgname}::git+https://github.com/emeryberger/scalene.git"
"git+https://github.com/emeryberger/Heap-Layers")
@@ -31,6 +31,6 @@ build() {
package() {
cd "$srcdir/${pkgname}"
- install -Dm755 libscalene.so ${pkgdir}/usr/lib/libscalene.so
+ install -Dm755 scalene/libscalene.so ${pkgdir}/usr/lib/libscalene.so
python setup.py install --root="${pkgdir}" --optimize=1
}