summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhilipp A2019-03-07 14:00:34 +0100
committerPhilipp A2019-03-07 14:00:34 +0100
commit6d20c0c1d5e950e4e9dcffb0e65c58706e1cffb4 (patch)
tree33e400bbbde990a9e8b754038b0b68cdc571c5de /PKGBUILD
parentc75681d22cf571a0ad17cfa84ff260ad85c676aa (diff)
downloadaur-6d20c0c1d5e950e4e9dcffb0e65c58706e1cffb4.tar.gz
v0.3.3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c301014065ad..012881b53de0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,21 @@
_name=scanpydoc
pkgname=python-$_name
-pkgver=0.3.1
+pkgver=0.3.3
pkgrel=1
pkgdesc='A series of Sphinx extensions to get easy to maintain, numpydoc style documentation.'
arch=(any)
url="https://github.com/theislab/$_name"
license=(GPL3)
depends=(python-sphinx python-get_version python-future-fstrings)
-makedepends=(python-pip)
-_wheel="$_name-$pkgver-py3-none-any.whl"
-source=("https://files.pythonhosted.org/packages/py3/${_name::1}/$_name/$_wheel")
-sha256sums=('0c1efda0ac0b0da0674e145419c4feb7f7eb45b0026eff62d1297b0dd052c324')
+_pyarch=py3
+_wheel="${_name/-/_}-$pkgver-$_pyarch-none-any.whl"
+source=("https://files.pythonhosted.org/packages/$_pyarch/${_name::1}/$_name/$_wheel")
+sha256sums=('91869ec0faed3c1f760c302098e85790ad4b69d7c859c4d0277613131c75cca8')
noextract=("$_wheel")
package() {
- cd "$srcdir"
- pip install --compile --no-deps --ignore-installed --root="$pkgdir" "$_wheel"
+ local site="$pkgdir/usr/lib/$(readlink /bin/python3)/site-packages"
+ mkdir -p "$site"
+ unzip "$_wheel" -d "$site"
}