summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRubenKelevra2023-03-23 03:28:38 +0100
committerRubenKelevra2023-03-23 03:28:38 +0100
commit72a8a579575bf91a507d6c52cfdd2c0d16040aa8 (patch)
treea6c92f553a5198932fe582f798ab6a27c96712ce /PKGBUILD
downloadaur-72a8a579575bf91a507d6c52cfdd2c0d16040aa8.tar.gz
intitial version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e9eaa4262509
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: @RubenKelevra <cyrond@gmail.com>
+
+pkgname='python-scantree'
+_module='scantree'
+pkgver='0.0.1'
+pkgrel=1
+pkgdesc='Flexible recursive directory iterator: scandir meets glob("**", recursive=True)'
+url="https://github.com/andhus/scantree"
+depends=('python')
+license=('MIT')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
+b2sums=('c891396ca2388457b3394e5e87cb29a92fe16f480e013ef560168cbeef4e2f9a1d9dab055945de34d2086032b12c8fec0d8a56f9dd0cdacd910250840e040490')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/python-scantree/LICENSE"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}