summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbitwave2019-09-02 13:00:38 +0200
committerbitwave2019-09-02 13:00:38 +0200
commit3b854e8bc8f6d45fa50dc71ee408358e518c781e (patch)
tree2aa911863337b715af1ee704c069c6d9a484330f /PKGBUILD
downloadaur-3b854e8bc8f6d45fa50dc71ee408358e518c781e.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9893176fb979
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+pkgbase='python-scenedetect'
+pkgname=('python-scenedetect')
+_module='scenedetect'
+pkgver='0.5.1.1'
+pkgrel=1
+pkgdesc="A cross-platform, OpenCV-based video scene detection program and Python library."
+url="https://github.com/Breakthrough/PySceneDetect"
+depends=('python')
+makedepends=('python-setuptools')
+license=('MIT')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
+sha256sums=('16526b5c1c1eca0fd060571b62f979a3a2b9a0c47a76edffcde56099cf1efe24')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}