summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhil Schaf2015-06-08 20:15:23 +0200
committerPhil Schaf2015-06-08 20:15:23 +0200
commit7262a6a22596ba0d41fd5c99d04d4d4849f6cd45 (patch)
tree87e4845809730ef3ec0b622889b1a1935d325e7b /PKGBUILD
downloadaur-7262a6a22596ba0d41fd5c99d04d4d4849f6cd45.tar.gz
aur4 migration
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 17 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a8b6fe5882a2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+_name=schema
+pkgname="python-$_name"
+pkgver=0.3.1
+pkgrel=1
+pkgdesc='Python module to validate and convert data structures.'
+arch=('i686' 'x86_64')
+url="https://github.com/halst/$_name"
+license=('MIT')
+depends=('python')
+source=("https://pypi.python.org/packages/source/s/$_name/$_name-$pkgver.tar.gz")
+sha1sums=('732ef97af28bcc8667ab3cbb1e8c1ac2668623d4')
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+ install -Dm644 {,"$pkgdir/usr/share/licenses/$pkgname/"}LICENSE-MIT
+} \ No newline at end of file