summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGrey Christoforo2021-01-14 12:53:56 +0100
committerGrey Christoforo2021-01-14 12:53:56 +0100
commit42f1580a07c010c8ef8e53cfd86356b20f5a22ca (patch)
tree5d92f1cff28256fb428ca01dfd21d8e454b73a33 /PKGBUILD
parent54ff931455317cbf7b5d9eafc8feb211eabac7fe (diff)
downloadaur-42f1580a07c010c8ef8e53cfd86356b20f5a22ca.tar.gz
bump version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD49
1 files changed, 36 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8b8f70aebea9..57a0ceabc9a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,48 @@
# Maintainer: Fabio Zanini <fabio.zanini _at_ fastmail.fm>
-pkgname='python-scikit-bio'
-pkgver=0.5.5
-pkgrel=3
+pkgname=python-scikit-bio
+pkgver=0.5.6
+pkgrel=1
pkgdesc="Python package providing data structures, algorithms, and educational resources for bioinformatics"
arch=('x86_64')
url="https://github.com/biocore/scikit-bio"
license=('BSD')
-groups=()
-depends=('python' 'python-future' 'python-decorator' 'python-six' 'python-contextlib2' 'python-natsort' 'python-bz2file' 'python-lockfile' 'python-pandas' 'python-scipy' 'python-numpy' 'python-matplotlib' 'python-requests' 'python-cachecontrol' 'python-msgpack' 'python-scikit-learn' 'python-hdmedians')
+depends=(
+python
+python-future
+python-decorator
+python-six
+python-contextlib2
+python-natsort
+python-bz2file
+python-lockfile
+python-pandas
+python-scipy
+python-numpy
+python-matplotlib
+python-requests
+python-cachecontrol
+python-msgpack
+python-scikit-learn
+python-hdmedians
+)
makedepends=('python-setuptools')
-conflicts=()
-replaces=()
-backup=()
options=(!emptydirs)
-install=
-source=("https://github.com/biocore/scikit-bio/archive/${pkgver}.tar.gz")
-md5sums=('e8ec41366d9eeda9bce3ec43c2af1159')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/biocore/scikit-bio/archive/${pkgver}.tar.gz")
+sha256sums=('69cf88626ff3803625aa65c7f6792f431318bd31f2b4d5c79e9a71cfc29c37ea')
+
+build() {
+ cd scikit-bio-${pkgver}
+ python setup.py build
+}
+
+check(){
+ cd scikit-bio-${pkgver}
+ python setup.py test || :
+}
package() {
- cd "$srcdir/scikit-bio-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1
+ cd scikit-bio-${pkgver}
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
}
# vim:set ts=2 sw=2 et: