summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authornoblehelm2022-02-15 14:21:40 -0300
committernoblehelm2022-02-15 14:21:40 -0300
commit8df30c69d90886b162a538ad24c5fc9aa5a6548e (patch)
tree1f449fe565ab79f376d55003cc52c524ad54dd70 /PKGBUILD
parent471ed8332f0b951ff7e0ade1ba47a87e61828bfc (diff)
downloadaur-8df30c69d90886b162a538ad24c5fc9aa5a6548e.tar.gz
Remove python2 package and dependencies
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 2 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1c6e0f0a9085..a40a79ba4935 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# If anything done wrong, please contact me
pkgbase="python-scikit-fuzzy"
-pkgname=("python-scikit-fuzzy" "python2-scikit-fuzzy")
+pkgname=("python-scikit-fuzzy")
_pkgname="scikit-fuzzy"
pkgver="0.4.2"
pkgrel="1"
@@ -11,7 +11,7 @@ pkgdesc="A fuzzy logic toolkit for SciPy"
arch=('any')
url="https://github.com/scikit-fuzzy/scikit-fuzzy"
license=('custom')
-makedepends=('python' 'python-setuptools' 'python-numpy' 'python-scipy' 'python-networkx' 'python2' 'python2-setuptools' 'python2-numpy' 'python2-scipy' 'python2-networkx')
+makedepends=('python' 'python-setuptools' 'python-numpy' 'python-scipy' 'python-networkx')
source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/${_pkgname}/${_pkgname}/archive/v${pkgver}.tar.gz")
sha256sums=('b4041e16b0e19a171bae3e830703e55fe17c35d41d81acd0457826b5112e9df3')
@@ -26,22 +26,11 @@ prepare() {
}
build() {
- msg "Building Python 2"
- cd "$srcdir/${_pkgname}-py2-${pkgver}"
- python2 setup.py build
-
msg "Building Python 3"
cd "$srcdir/${_pkgname}-${pkgver}"
python setup.py build
}
-package_python2-scikit-fuzzy() {
- depends=('python2' 'python2-numpy' 'python2-scipy' 'python2-networkx')
- cd "$srcdir/${_pkgname}-${pkgver}"
- python setup.py install --root="$pkgdir"/ --optimize=1
- install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt"
-}
-
package_python-scikit-fuzzy() {
depends=('python' 'python-numpy' 'python-scipy' 'python-networkx')
cd "$srcdir/${_pkgname}-${pkgver}"