summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAdelmo Junior2017-03-14 23:00:08 -0300
committerAdelmo Junior2017-03-14 23:00:08 -0300
commitb955c2d279c77d23aa82ecafed6a4172e1078209 (patch)
treeea86dcae04b569bae55ca1ec7f2fac01497f68d5 /PKGBUILD
downloadaur-b955c2d279c77d23aa82ecafed6a4172e1078209.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD54
1 files changed, 54 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d97d5624fe76
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Adelmo Junior <noblehelm@gmail.com>
+# Done while using both community:python-scikit-learn and AUR:python-keras as base, so credit goes to them
+# If anything done wrong, please contact me
+
+pkgbase="python-scikit-fuzzy"
+pkgname=("python-scikit-fuzzy" "python2-scikit-fuzzy")
+_pkgname="scikit-fuzzy"
+pkgver="0.2"
+pkgrel="1"
+pkgdesc="A fuzzy logic toolkit for SciPy"
+arch=('any')
+url="https://github.com/scikit-fuzzy/scikit-fuzzy"
+license=('custom')
+makedepends=('python' 'python-setuptools' 'python-numpy' 'python-scipy' 'python-networkx' 'python2' 'python2-setuptools' 'python2-numpy' 'python2-scipy' 'python2-networkx')
+source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/${_pkgname}/${_pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=('e9d974e6ea9f660934cbbc0edfc7091ed0ea9e3b2cc242b89a0f821560e9f118')
+
+prepare() {
+ cd "$srcdir"
+ cp -a "${_pkgname}-${pkgver}" "${_pkgname}-py2-${pkgver}"
+ cd "${_pkgname}-${pkgver}"
+ sed -e "s|#![ ]*/usr/bin/python$|#!/usr/bin/python2|" \
+ -e "s|#![ ]*/usr/bin/env python$|#!/usr/bin/env python2|" \
+ -e "s|#![ ]*/bin/env python$|#!/bin/env python2|" \
+ -i $(find . -name '*.py')
+}
+
+build() {
+ msg "Building Python 2"
+ cd "$srcdir/${_pkgname}-py2-${pkgver}"
+ python2 setup.py build
+
+ msg "Building Python 3"
+ cd "$srcdir/${_pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package_python2-scikit-fuzzy() {
+ depends=('python2' 'python2-numpy' 'python2-scipy' 'python2-networkx')
+ cd "$srcdir/${_pkgname}-${pkgver}"
+ python setup.py install --root="$pkgdir"/ --optimize=1
+ install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt"
+}
+
+package_python-scikit-fuzzy() {
+ depends=('python' 'python-numpy' 'python-scipy' 'python-networkx')
+ cd "$srcdir/${_pkgname}-${pkgver}"
+ python setup.py install --root="$pkgdir"/ --optimize=1
+ install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt"
+}
+
+# vim:set ts=2 sw=2 et:
+
+