summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorUniversebenzene2020-12-15 20:17:29 +0800
committerUniversebenzene2020-12-15 20:17:29 +0800
commit249765942087258952a420be2c9e28f45df45bd0 (patch)
tree251a5e8a2df39a5111b11c9defe5f62d5e7a21cd /PKGBUILD
parent78491290b0942e2e1de23fcda13b3f058ee433d2 (diff)
downloadaur-249765942087258952a420be2c9e28f45df45bd0.tar.gz
Update to version 0.18.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 15 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 882fd7cd2356..ec0c1b57466c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,25 +5,32 @@
pkgbase=python-scikit-image
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}")
-pkgver=0.17.2
-pkgrel=2
+pkgver=0.18.0
+pkgrel=1
pkgdesc="Image processing routines for SciPy"
arch=('i686' 'x86_64')
url="http://scikit-image.org/"
license=('BSD')
-makedepends=('cython>=0.23.4')
-depends=('python-numpy>=1.15' 'python-scipy>=1.0.1' 'python-matplotlib>3.0.0' 'python-networkx>=2.0' 'python-pillow>=4.3.0' 'python-pywavelets>=1.1.1' 'python-imageio>=2.3.0' 'python-tifffile>=2019.7.26')
-checkdepends=('python-pytest' 'python-pytest-cov' 'python-pytest-flake8' 'python-pytest-localserver')
-optdepends=('python-pyqt5: for imshow(x, fancy=True) and skivi'
+makedepends=('cython>=0.29.21')
+depends=('python-numpy>1.18.0' 'python-scipy>=1.0.1' 'python-matplotlib>3.0.0' 'python-networkx>=2.0' 'python-pillow>7.1.1' 'python-pywavelets>=1.1.1' 'python-imageio>=2.3.0' 'python-tifffile>=2019.7.26')
+checkdepends=('python-pytest>=5.2.0'
+ 'python-pytest-cov>=2.7.0'
+ 'python-pytest-flake8'
+ 'python-pytest-localserver'
+ 'python-pooch') #>=1.3.0
+# 'python-pytest-faulthandler')
+optdepends=('python-pyqt5: for imshow[x, fancy=True] and skivi'
'python-qtpy'
'freeimage: for reading various types of image file formats'
'python-pyamg: fast cg_mg mode of random walker segmentation'
'python-astropy: Provides FITS I/O capability'
'python-imread: Optional I/O plugin providing most standard formats'
- 'python-simpleitk: Optional I/O plugin providing a wide variety of formats. including specialized formats using in medical imaging')
+ 'python-simpleitk: Optional I/O plugin providing a wide variety of formats. including specialized formats using in medical imaging'
+ 'python-dask: used to speed up certain functions'
+ 'python-cloudpickle: necessary to provide the 'processes' scheduler for dask')
options=('!emptydirs')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-sha256sums=('bd954c0588f0f7e81d9763dc95e06950e68247d540476e06cb77bcbcd8c2d8b3')
+sha256sums=('a0c78a117080101dbeeaa430804fe9512575cf2696ddbf822a7ee30d0776f5da')
build() {
cd ${srcdir}/${_pyname}-${pkgver}