summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGordian Edenhofer2020-01-11 13:31:06 +0100
committerGordian Edenhofer2020-01-11 13:33:59 +0100
commitbcdf0d593c3d5395fad413f4c841c5326ae5bb22 (patch)
tree8d2f63d2336f53e69d09bcbe859d62852d1c0e1c /PKGBUILD
parentbd5ca0de1d9e1f2ad507a8e25168dc1b3306017b (diff)
downloadaur-bcdf0d593c3d5395fad413f4c841c5326ae5bb22.tar.gz
Prune python2 versions of packages due to EOL
Drop python2-nautilus. upgpkg: bcc 0.12.0-1 upgpkg: python-gensim 3.8.1-1 upgpkg: python-scikit-surprise 1.1.0-2 upgpkg: python-scikit-surprise-git 1.0.4.r112.gef3ed6e-1 upgpkg: python-smart_open 1.9.0-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 10 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c1f01234a2ca..4de5f626e4f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,10 +8,16 @@ pkgdesc="Python scikit for building and analyzing recommender systems"
arch=('any')
license=('BSD-3-Clause')
url="https://github.com/NicolasHug/${_reponame}"
-depends=()
-makedepends=('git' 'python-setuptools' 'cython' 'python-numpy')
-provides=()
-conflicts=()
+depends=('python-joblib' 'python-numpy' 'python-scipy' 'python-six')
+optdepends=("flake8: code linting to comply with contributing standards"
+ "python-pandas: dataframe handling"
+ "python-pytest: test suite"
+ "python-sphinx: documentation generator"
+ "python-sphinx_rtd_theme: Read The Docs theme for documentation generator"
+ "python-sphinxcontrib-spelling: spelling extension for documentation generator")
+makedepends=('git' 'python-setuptools' 'cython')
+provides=("python-scikit-surprise=${pkgver}")
+conflicts=("python-scikit-surprise")
source=("git+https://github.com/NicolasHug/${_reponame}")
sha512sums=('SKIP')
@@ -31,16 +37,6 @@ build() {
}
package() {
- depends=('python-joblib' 'python-numpy' 'python-scipy' 'python-six')
- optdepends=("flake8: code linting to comply with contributing standards"
- "python-pandas: dataframe handling"
- "python-pytest: test suite"
- "python-sphinx: documentation generator"
- "python-sphinx_rtd_theme: Read The Docs theme for documentation generator"
- "python-sphinxcontrib-spelling: spelling extension for documentation generator")
- provides=("python-scikit-surprise=${pkgver}")
- conflicts=("python-scikit-surprise")
-
cd "${srcdir}/${_reponame}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
ln -s surprise "${pkgdir}/usr/bin/surprise3"