summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGordian Edenhofer2020-01-11 13:02:14 +0100
committerGordian Edenhofer2020-01-11 13:02:14 +0100
commitbd5ca0de1d9e1f2ad507a8e25168dc1b3306017b (patch)
tree6363c25db97cb8221b7a7529a51f36f077671d21 /PKGBUILD
parent1d9ea0779dee65c364712c3e2f6004636e950d49 (diff)
downloadaur-bd5ca0de1d9e1f2ad507a8e25168dc1b3306017b.tar.gz
upgpkg: python-scikit-surprise 1.1.0-2
Drop the python2 version of the package. upgpkg: python-scikit-surprise-git 1.0.4.r112.gef3ed6e-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 8 insertions, 36 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7c2b5018911e..c1f01234a2ca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,17 @@
# Maintainer: Gordian Edenhofer <gordian.edenhofer@gmail.com>
-pkgbase=python-scikit-surprise-git
-pkgname=("python-scikit-surprise-git" "python2-scikit-surprise-git")
+pkgname=python-scikit-surprise-git
_reponame="Surprise"
-pkgver=1.0.4.r73.g633ab47
+pkgver=1.0.4.r112.gef3ed6e
pkgrel=1
pkgdesc="Python scikit for building and analyzing recommender systems"
arch=('any')
license=('BSD-3-Clause')
url="https://github.com/NicolasHug/${_reponame}"
-depends=('')
-makedepends=('git' 'python-setuptools' 'python2-setuptools' 'cython' 'cython2' 'python-numpy' 'python2-numpy')
-provides=("")
-conflicts=("")
+depends=()
+makedepends=('git' 'python-setuptools' 'cython' 'python-numpy')
+provides=()
+conflicts=()
source=("git+https://github.com/NicolasHug/${_reponame}")
sha512sums=('SKIP')
@@ -24,23 +23,14 @@ pkgver() {
)
}
-prepare() {
- cp -a "${srcdir}/${_reponame}"{,-py2}
-}
-
build() {
cd "${srcdir}/${_reponame}"
python setup.py clean
rm -rf build dist
python setup.py build
-
- cd "${srcdir}/${_reponame}-py2"
- python2 setup.py clean
- rm -rf build dist
- python2 setup.py build
}
-package_python-scikit-surprise-git() {
+package() {
depends=('python-joblib' 'python-numpy' 'python-scipy' 'python-six')
optdepends=("flake8: code linting to comply with contributing standards"
"python-pandas: dataframe handling"
@@ -52,26 +42,8 @@ package_python-scikit-surprise-git() {
conflicts=("python-scikit-surprise")
cd "${srcdir}/${_reponame}"
- python setup.py install --root="${pkgdir}" --optimize=1
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
ln -s surprise "${pkgdir}/usr/bin/surprise3"
install -Dm644 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname/-git//}/LICENSE"
}
-
-package_python2-scikit-surprise-git() {
- depends=('python2-joblib' 'python2-numpy' 'python2-scipy' 'python2-six')
- optdepends=("python2-flake8: code linting to comply with contributing standards"
- "python2-pandas: dataframe handling"
- "python2-pytest: test suite"
- "python2-sphinx: documentation generator"
- "python2-sphinx_rtd_theme: Read The Docs theme for documentation generator"
- "python2-sphinxcontrib-spelling: spelling extension for documentation generator")
- provides=("python2-scikit-surprise=${pkgver}")
- conflicts=("python2-scikit-surprise")
-
- cd "${srcdir}/${_reponame}-py2"
- python2 setup.py install --root="${pkgdir}" --optimize=1
- mv "${pkgdir}/usr/bin/surprise"{,2}
-
- install -Dm644 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname/-git//}/LICENSE"
-}