summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDylan Delgado2023-06-18 11:43:56 -0400
committerDylan Delgado2023-06-18 11:43:56 -0400
commit0205c70a4db2cc3787521febb86cc974214849e3 (patch)
tree494ef6776528c1b76c6cb47489c03642a426a048 /PKGBUILD
parent17e7f5ac0dfd74d783051964b268c560292d5e17 (diff)
downloadaur-0205c70a4db2cc3787521febb86cc974214849e3.tar.gz
update versioning, update python versioning to 3.11
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1da075d48a64..5e6b62e5e23e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_name=scipy
pkgname=python-scipy-git
-pkgver=v0.17pre.r14548.gf71fe40cdc
+pkgver=0.17pre.r15964.g0a6aad03f6
pkgrel=1
pkgdesc="SciPy is open-source software for mathematics, science and engineering. Git version"
arch=('x86_64')
@@ -20,7 +20,7 @@ sha256sums=('SKIP')
pkgver() {
cd "$_name"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
@@ -36,7 +36,7 @@ check() {
cd scipy
python setup.py config_fc install \
--prefix=/usr --root="$srcdir"/test --optimize=1
- export PYTHONPATH="$srcdir"/test/usr/lib/python3.10/site-packages
+ export PYTHONPATH="$srcdir"/test/usr/lib/python3.11/site-packages
cd ..
python -c "from scipy import test; test('full')"
}