summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJingbei Li2020-02-03 11:31:15 +0800
committerJingbei Li2020-02-03 11:31:15 +0800
commitc039fd7b245f0031ad8e0dea9736b7d0d20b7496 (patch)
tree70e6ec08f91928e7336a11000ebf5c05850589e1 /PKGBUILD
parentaa0e19c9753c326edc712472142f658734a99c1e (diff)
downloadaur-c039fd7b245f0031ad8e0dea9736b7d0d20b7496.tar.gz
using gcc9's headers
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5368fd35c723..9c75254520a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
pkgname='python-scipy-mkl'
pkgver=1.4.1
-pkgrel=1
+pkgrel=2
pkgdesc="SciPy is open-source software for mathematics, science, and engineering."
arch=('x86_64')
url="http://www.scipy.org/"
@@ -16,7 +16,7 @@ license=('BSD')
depends=('intel-compiler-base' 'intel-fortran-compiler' 'intel-mkl' 'python-numpy')
provides=("python-scipy=$pkgver")
conflicts=('python-scipy')
-makedepends=('gcc8' 'pybind11' 'python-setuptools')
+makedepends=('pybind11' 'python-setuptools')
#checkdepends=('python-pytest')
optdepends=('python-pillow: for image saving module')
source=("https://github.com/scipy/scipy/releases/download/v${pkgver}/scipy-${pkgver}.tar.gz" 'build.sh')
@@ -25,7 +25,7 @@ sha512sums=('79407a2cbb4ba29c0941570181df4d7835e5791e50a3abef9b63c2fc5b15308a2e4
build() {
export LDFLAGS="-Wall -shared"
- export __INTEL_PRE_CFLAGS="-I/usr/lib/gcc/x86_64-pc-linux-gnu/8.3.0/include/c++ -I/usr/lib/gcc/x86_64-pc-linux-gnu/8.3.0/include/c++/x86_64-pc-linux-gnu/"
+ #export __INTEL_PRE_CFLAGS="-I/usr/lib/gcc/x86_64-pc-linux-gnu/8.3.0/include/c++ -I/usr/lib/gcc/x86_64-pc-linux-gnu/8.3.0/include/c++/x86_64-pc-linux-gnu/"
cd scipy-${pkgver}
sh ${srcdir}/build.sh